6 Replies Latest reply on Apr 10, 2013 5:51 PM by SaichandVaranasi

    "Quickstart" project for Endeca 3.0

    Marco Snels
      Hi,

      Is there a "quickstart" project for Endeca 3.0?
      I have imported the gettingstarted sample data into the Endeca Server, but I also would like the Integrator and Studio project, because I have some problems getting the web service component to work with Endeca 3.0.

      Thanks,

      Marco Snels
        • 1. Re: "Quickstart" project for Endeca 3.0
          JaniceM
          The Getting Started Guide includes the instructions for importing the sample application.

          http://docs.oracle.com/cd/E39271_01/general.300/eid_getting_started/toc.htm#About%20this%20guide

          Janice
          • 2. Re: "Quickstart" project for Endeca 3.0
            RLJII
            Marco,

            In version 3.0, the "quickstart" is replaced by a "Getting Started" project. For details, see http://docs.oracle.com/cd/E37502_01/general.300/eid_getting_started/toc.htm#About%20this%20guide

            RLJII
            • 3. Re: "Quickstart" project for Endeca 3.0
              902735
              Hi

              I have installed integrator 3.0 and i tried to run the create data domain graph. I am getting the following error

              INFO [main] - Running with CloverETL library version 3.3.0 build#036 compiled 12/02/2013 18:45:45
              INFO [main] - Running on 2 CPU(s), OS Windows Server 2008, architecture amd64, Java version 1.7.0_07, max available memory for JVM 932096 KB
              INFO [main] - Loading default properties from: defaultProperties
              INFO [main] - Graph definition file: graph/InitDataDomain.grf
              INFO [main] - Graph revision: 1.2 Modified by: Administrator Modified: Tue Apr 09 05:46:25 GMT-06:00 2013
              INFO [main] - Checking graph configuration...
              INFO [main] - Graph configuration is valid.
              INFO [main] - Graph initialization (InitDataDomain)
              INFO [main] - [Clover] Initializing phase: 0
              INFO [main] - Messenger configuration context loaded.
              INFO [main] - Axis2-specific client dispatcher established for service manage based on WSDL document.
              INFO [main] - Axis2 modules engaged for client dispatcher.
              INFO [main] - WS-Policy expressions processed.
              INFO [main] - Message validation on request is disabled.
              INFO [main] - Message validation on response is disabled.
              INFO [main] - Asynchronous messenger initialized for operation '{http://www.endeca.com/endeca-server/manage/1}manage#managePort#createDataDomain'.
              INFO [main] - [Clover] phase: 0 initialized successfully.
              INFO [WatchDog] - Starting up all nodes in phase [0]
              INFO [WatchDog] - Successfully started all nodes in phase!
              INFO [CREATE_DATA_DOMAIN_0] - Web Service Client Fault response:
              <env:Fault xmlns:env="http://schemas.xmlsoap.org/soap/envelope/"><faultcode>env:Server</faultcode><faultstring>OES-000096: Error during manage service operation: javax.xml.soap.SOAPException: javax.xml.soap.SOAPException: Message send failed: Connection refused; javax.xml.soap.SOAPException: Message send failed: Connection refused; Message send failed: Connection refused; Connection refused</faultstring><detail><ns3:manageFault xmlns:ns3="http://www.endeca.com/endeca-server/manage/1/0" xmlns:ns2="http://www.endeca.com/endeca-server/types/1/0"><ns3:reason>javax.xml.soap.SOAPException: javax.xml.soap.SOAPException: Message send failed: Connection refused</ns3:reason><ns3:reason>javax.xml.soap.SOAPException: Message send failed: Connection refused</ns3:reason><ns3:reason>Message send failed: Connection refused</ns3:reason><ns3:reason>Connection refused</ns3:reason></ns3:manageFault></detail></env:Fault>
              INFO [CREATE_DATA_DOMAIN_0] - Error occured while executing web service call. Printing request/response details:
              INFO [CREATE_DATA_DOMAIN_0] - Web Service Client request header:
              null
              INFO [CREATE_DATA_DOMAIN_0] - Web Service Client request body:
              <ns:createDataDomain xmlns:ns="http://www.endeca.com/endeca-server/manage/1/0">
              <ns:name>NewDS</ns:name>
              <ns:ddProfileName>default</ns:ddProfileName>
              <ns:enabled>true</ns:enabled>
              </ns:createDataDomain>
              INFO [CREATE_DATA_DOMAIN_0] - Web Service Client response:
              null
              ERROR [WatchDog] - Graph execution finished with error
              ERROR [WatchDog] - Node CREATE_DATA_DOMAIN finished with status: ERROR caused by: OES-000096: Error during manage service operation: javax.xml.soap.SOAPException: javax.xml.soap.SOAPException: Message send failed: Connection refused; javax.xml.soap.SOAPException: Message send failed: Connection refused; Message send failed: Connection refused; Connection refused
              ERROR [WatchDog] - Node CREATE_DATA_DOMAIN error details:
              org.apache.axis2.AxisFault: OES-000096: Error during manage service operation: javax.xml.soap.SOAPException: javax.xml.soap.SOAPException: Message send failed: Connection refused; javax.xml.soap.SOAPException: Message send failed: Connection refused; Message send failed: Connection refused; Connection refused
                   at org.apache.axis2.description.OutInAxisOperationClient$NonBlockingInvocationWorker.run(OutInAxisOperation.java:451)
                   at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
                   at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
                   at java.lang.Thread.run(Thread.java:722)
              INFO [WatchDog] - [Clover] Post-execute phase finalization: 0
              INFO [WatchDog] - [Clover] phase: 0 post-execute finalization successfully.
              INFO [WatchDog] - Execution of phase [0] finished with error - elapsed time(sec): 0
              ERROR [WatchDog] - !!! Phase finished with error - stopping graph run !!!
              INFO [WatchDog] - -----------------------** Summary of Phases execution **---------------------
              INFO [WatchDog] - Phase# Finished Status RunTime(sec) MemoryAllocation(KB)
              INFO [WatchDog] - 0 ERROR 0 30557
              INFO [WatchDog] - ------------------------------** End of Summary **---------------------------
              INFO [WatchDog] - WatchDog thread finished - total execution time: 0 (sec)
              INFO [main] - Freeing graph resources.
              ERROR [main] - Execution of graph failed !




              Any idea why i am getting this error.
              Pls help

              Thanks
              • 4. Re: "Quickstart" project for Endeca 3.0
                Branchbird - Pat
                Is your Endeca Server instance running?

                Do you get a response when you attempt to access one of the WSDLs?

                (Ex: http://localhost:7001/endeca-server/ws/ingest/?wsdl )

                Patrick Rafferty
                Branchbird
                • 5. Re: "Quickstart" project for Endeca 3.0
                  Greg Rakers-Oracle
                  Same here... I moved my endeca server domain to port 7002. Then you need to modify the EndecaCmd.properties file with the correct port number.
                  The "Manage Endpoint" is available on <host>:7002/endeca-server/ws/manage and displays the page. Still I get the error below.

                  So when executing: endeca-cmd import-dd test --offline-name sh

                  SEVERE: Error while invoking endpoint "http://<hostname>:7002/endeca-server/ws/manage" from client
                  endeca-cmd encountered a problem.
                  caused by:
                  The Endeca Server returned an error: OES-000096: Error during manage service ope
                  ration: javax.xml.soap.SOAPException: javax.xml.soap.SOAPException: Message send
                  failed: Connection refused: connect; javax.xml.soap.SOAPException: Message send
                  failed: Connection refused: connect; Message send failed: Connection refused: c
                  onnect; Connection refused: connect
                  caused by:
                  OES-000096: Error during manage service operation: javax.xml.soap.SOAPException:
                  javx.xml.soap.SOAPException: Message send failed: Connection refused: connect;
                  javax.xml.soap.SOAPException: Message send failed: Connection refused: connect;
                  Message send failed: Connection refused: connect; Connection refused: connect
                  javax.xml.soap.SOAPException: javax.xml.soap.SOAPException: Message send faile
                  d: Connection refused: connect
                  javax.xml.soap.SOAPException: Message send failed: Connection refused: connect

                  Message send failed: Connection refused: connect
                  Connection refused: connect
                  • 6. Re: "Quickstart" project for Endeca 3.0
                    SaichandVaranasi
                    Hi Greg,

                    Not sure whether you changed your port number in below location ?

                    endeca_weblogic\user_projects\domains\base_domain\config\EndecaServer.properties (endeca-webserver-port)


                    Thanks,
                    Saichand