4 Replies Latest reply: Apr 1, 2013 3:49 AM by MFadel RSS

    Problem with "invokeAction"!

      Hello Everyone,

      I'm using JDeveloper I'm trying to create an empty form using this link [http://sqltech.cl/doc/oas10gR31/web.1013/b25947/web_form006.htm]. I was able to
      initialize an empty form using :

      <invokeAction Binds="Create" id="invokeCreate" Refresh="renderModel"
      RefreshCondition="${!adfFacesContext.postback and empty

      in my page definition.

      However, whenever i click on on the navigation item that takes me to the empty form, the web application freezes, and stops working. I have to rerun the application once again for it to work.
      I was using Firefox while this happened. When i tried using internet explorer, it worked great and didn't freeze! Has anyone had such a problem before?

        • 1. Re: Problem with "invokeAction"!
          Timo Hahn
          as you are using and not 10g (10.3.1?) this tutorial is not meant for your version.
          You should use a bounded task flow with a start activity which resets the form. Depending on the use case this can be done by calling createInsert on the vo you want to enter data into, or by clearing the inputFiled which are bound to a bean or something else.
          For a sample of the first check http://tompeez.wordpress.com/2012/12/01/jdeveloper-11-1-1-5-0-use-router-to-create-new-row-or-edit-existing/

          • 2. Re: Problem with "invokeAction"!
            Thanks for your reply Timo,

            That's the first time i've heard of the router! In your sample application, you set the default outcome to "edit". So this means there's only 2 outcomes : insert and edit in the router's functionality?
            And that you set the default to be edit?

            By the way, this is just a general question, I'm not trying to do anything for now.

            • 3. Re: Problem with "invokeAction"!
              Timo Hahn
              routers are not only for create/edit but can have multiple outcomes. Check the doc http://docs.oracle.com/cd/E35521_01/web.111230/e16182/taskflows_activities.htm#ADFFD1673 to find out more about how to use them.

              • 4. Re: Problem with "invokeAction"!
                I'll check them out now!

                Thanks Timo:)