2 Replies Latest reply on Apr 3, 2013 2:10 PM by user11391721

    Filesystem check & unusable VNC


      I have a strange problem with connecting to a VM console, it's showing only lines with no input available.
      Here is a screenshot of the TightVNC connection:

      This appears right after the boot screens and the last thing I can see on the VNC output is an enforced filesystem check showing %done. The VM filesystem seems to be corrupted, but would this have an impact on not being able to use the console? The VM is not available across the network at this point.

      Please advise how I could save this VM :-) Thank you.

      This is on Oracle VM 3.0.3 and the VM running Oracle Enterprise Linux 5.
        • 1. Re: Filesystem check & unusable VNC
          I repaired the filesystem by attaching PartitionMagic and using fsck from there (any live linux would do of course, it's just what I had available), however, why does the automatic fsck on startup have the impact of not being able to use the console? How is it related? I think it stalled once fsck asked for input ..
          • 2. Re: Filesystem check & unusable VNC
            I am interested in others experience on this and what work-arounds and/or fixes they have employed...

            I have been having similar screen variances upon boot up of OEL Linux guests on 3.2.1 and it is kinda scary.

            It seems inconsistent and after multiple attempts I sometimes get through.

            Sometimes on a guess of that the screen is showing I have typed in the password to login and it continued... Sometimes I can press return and see the green/red boxes move up the screen.

            I have been doing lots of cloning so some times Kudzu is kicking in and I can't see it or miss it due to timing.

            I have also had a few occurrences of the console not being available at all even though in some cases the machine fully boots up and rebooting the Oracle VM Manager server seems to fix that. I suspect restarting a service or a set of services on the OVM Manager machine would be sufficient but instead I have been shutting it down, cold backing it up, and then starting it back up...

            Edit: One thing I haven't tried yet is trying to access the VM's VNC directly from the OVS. I used to do that on OVM 2.X when I had issues but haven't tried it on OVM 3. Maybe taking VNC reflection from the guest to the OVS Server Host to the OVM Manager to the brower on my PC via Java would result in a more stable console... The key to that is finding out which IP and port to use (likely on the OVS Server)...

            Edited by: user11391721 on Apr 3, 2013 7:06 AM Fix typos/grammar & More thoughts...