This discussion is archived
2 Replies Latest reply: Apr 4, 2013 11:27 AM by 1000818 RSS

vdbench waiting for slave to shutdown after run elapsed time has completed

1000818 Newbie
Currently Being Moderated
We have a test system running with 2 hosts. We start vdbench from our local (master) host that has a run definition set for 12s. The test does seem to stop after 12s (we are not longer seeing any output logging) but on the local host we continuously see message about waiting for slave to shutdown:

local host
SlaveOnMaster terminating: host1-0
SlaveStarter terminating: host1-0
SlaveOnMaster terminating: host2-0
SlaveStarter terminating: host2-0
Waiting for slave shutdown: host2-0
Waiting for slave shutdown: host2-0
......

On the remote host we see

Vdbench rsh deamon: waiting for new users


Is this expected?

We are running vdbench on Microsoft Server 2012 and are starting vdbench on the remote host machine prior to starting vdbench on the local host using the command:

./vdbench rsh


we then start vdbench on local host using command:

vdbench -f vdbench_profile
  • 1. Re: vdbench waiting for slave to shutdown after run elapsed time has completed
    Henk Vandenbergh Explorer
    Currently Being Moderated
    You're the very first to post a question on this forum, and the very first time I am using any OTN forum.
    My typical answer would be "please send me the complete Vdbench output directory", but I can't find a way for you to attach anything to this post. If you know how to do that, wonderful, 'teach me master'.
    So without any real data I can only guess.

    But, even with data, this would be a very difficult problem to identify, because it appears to me that the problem may be outside of Vdbench control. Did the Vdbench slave that started on your remote system really complete, or is it still running? In other word, could the Vdbench master be waiting for a slave that has terminated, or is it waiting for a slave that has NOT terminated?
    I have never run Vdbench on 2012 Server, I recall having had some problems like this years ago in the Windows 2000 days.

    That said, it is interesting to note that you START from Windows, but then start Vdbench RSH using './vdbench rsh', with emphasis on the forward slash. Your remote systems are Unix systems? If so, knowing that Windows can be tricky, why not completely run from Unix?

    Sorry, not much of an answer, but this is the best I can do at this time.

    Henk.
  • 2. Re: vdbench waiting for slave to shutdown after run elapsed time has completed
    1000818 Newbie
    Currently Being Moderated
    Hi - thank you for the reply! We are running both master and slave on windows - typo on my part, we start on slave using vdbench rsh command directly in DOS window. I can't see a way to attach file either.

    Have run several times since I posted and sometimes we don't see the waiting for shutdown and sometimes we do. we'll keep an eye on it. Looks like output report is ok though so we will continue on.

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points