7 Replies Latest reply on Apr 18, 2013 9:17 AM by JohnGoodwin

    Shared Services: adding users to Planning

    Pedro Soares
      Hi,

      I'm having a problem creating users to and provisioning them to Planning. I'm not getting any error in the web interface but the users are not being added to the relational Planning database (HSP_USERS), however groups are. When I can also add the created users to a group but they are failing in the Planning logs with reference constraints, because the user is not present on the users table.

      Does shared services have a log to check if I'm having any error while creating the users?

      Thank you
        • 1. Re: Shared Services: adding users to Planning
          Celvin Kattookaran
          The users will be created in CSS_USERS table, if you are on 11.1.2.x version, if not you can use an LDAP browser to check then in Shared Services open ldap.

          I think there is an option to create a report in Shared Services.

          Regards

          Celvin

          http://www.orahyplabs.com

          Please mark the responses as helpful/correct if applicable
          • 2. Re: Shared Services: adding users to Planning
            Pedro Soares
            Hi,

            The user are being created on shared services and they exist on the CSS_USERS table. The problem seems to be adding them to Planning. I added them to a native group, and it seems to me that the process that Planning does is to add those users to a the HSP_USERS table and the group to the HSP_GROUP table, but the user is not being added and then the reference constraint is activated.
            • 3. Re: Shared Services: adding users to Planning
              JohnGoodwin
              If you provision a user/group in Shared Services against a planning application the user/group is not instantly added to the planning tables, I usually find running provisionusers utility a good sure way to push the information into planning.
              I am not sure why you are getting reference constraints as they usually occur when there is an issue with ids/names in the tables and a duplicate entry is trying to be entered.

              Cheers

              John
              http://john-goodwin.blogspot.com/
              • 4. Re: Shared Services: adding users to Planning
                Celvin Kattookaran
                As John, mentioned you can use ProvisionUsers to push information to Planning.

                http://docs.oracle.com/cd/E17236_01/epm.1112/hp_admin_11122/ch03s12.html

                You can also try Migrate identities if a users position is changed (not sure whether ProvisionUsers take care of this)

                http://docs.oracle.com/cd/E17236_01/epm.1112/hp_admin_11122/ch03s13.html

                Regards

                Celvin

                http://www.orahyplabs.com

                Please mark the responses as helpful/correct if applicable
                • 5. Re: Shared Services: adding users to Planning
                  Pedro Soares
                  I tried that, but I get an error doing it:

                  CSS_USERS
                  -----------------
                  SID: native://nvid=1366b87752f6b19d:3de04b64:13dac88ee6e:-7528?USER     
                  Username: bcorreia

                  E:\Hyperion\user_projects\epmsystem1\Planning\planning1>ProvisionUsers /ADMIN:admin /A:FrcApp /U:bcorreia

                  Found HBR product = ESSBASE_PRODUCT
                  Found HBR product = ESSBASE_PRODUCT
                  *=2013-04-04 13:58:01,054 WARN main com.hyperion.hbr.security.HbrSecurityAPI - Er*
                  ror retrieving user by identity
                  - Error retrieving user by identity
                  Embedded HBR initialized.

                  E:\Hyperion\user_projects\epmsystem1\Planning\planning1>ProvisionUsers /ADMIN:admin /A:FrcApp /U:bcorreia

                  Loaded Version of Essbase RTC: 0xb1210
                  *Thu Apr 04 13:58:01 BST 2013 :: [Thu Apr 04 13:58:01 BST 2013] FrcApp: Synchroni*
                  *zing the following users with user provisioning: [bcorreia]*
                  Thu Apr 04 13:58:01 BST 2013 :: FrcApp: Error occurred while synchronizing: Erro
                  *rs occured during syncrhonization: [EPMCSS-07004: Failed to authorize the user a*
                  *ction. Principal is null. Provide valid user principal to access.[GET_USER_BY_ID*
                  *ENTITY]]*

                  Have you seen this before?

                  Thank you
                  • 6. Re: Shared Services: adding users to Planning
                    Pedro Soares
                    Hi,

                    I dug into the logs and found the following:

                    EPMCSS-00001: Failed to initialize EPM Shared Services security instance. Component SYSTEM9/FOUNDATION_SERVICES_PRODUCT/SHARED_SERVICES_PRODUCT is null in EPM System Registry. Verify EPM System Registry configuration.
                    at com.hyperion.css.registry.RegistryManager.initRegistry(RegistryManager.java:109)
                    at com.hyperion.css.registry.RegistryManager.<init>(RegistryManager.java:94)
                    at com.hyperion.css.registry.RegistryManager.getInstance(RegistryManager.java:131)
                    at com.hyperion.css.CSSSystemFactory.getCSSMode(CSSSystemFactory.java:102)
                    at com.hyperion.css.CSSSystemFactory.getCSSSystem(CSSSystemFactory.java:71)
                    at com.hyperion.css.CSSSystem.initCSSSystem(CSSSystem.java:319)
                    at com.hyperion.css.CSSSystem.getInstance(CSSSystem.java:273)

                    [Thu Apr 26 12:51:14 2012]Local/ESSBASE0///1876/Info(1051283)
                    Retrieving License Information Please Wait...

                    [Thu Apr 26 12:51:14 2012]Local/ESSBASE0///1876/Info(1051286)
                    License information retrieved.

                    [Thu Apr 26 12:52:01 2012]Local/ESSBASE0///1876/Error(1051223)
                    Single Sign On function call [css_init] failed with error [CSS Error: CSS method invocation error: getInstance: Failed to get CSSSystem instance, please check SharedServices_Security_Client.log for more information]

                    [Thu Apr 26 12:52:01 2012]Local/ESSBASE0///1876/Info(1051198)
                    Single Sign-On Initialization Failed !

                    So it seems it's a problems in the EPM System Registry. Can you advise me please? How can I clean the EPM System Registry of problems? I think this might have happened when I changed the database servers, but I configured the registry again and I thought it was healthy again since I only had problems some days ago when I tried to add new users.

                    Thank you
                    • 7. Re: Shared Services: adding users to Planning
                      JohnGoodwin
                      On your essbase server check the details in reg.properties are correct, it will be located in <MIDDLEWARE_HOME>\user_projects\epmsystem1\config\foundation\11.1.2.0

                      Cheers

                      John
                      http://john-goodwin.blogspot.com/