5 Replies Latest reply: Apr 5, 2013 4:11 PM by DBelt RSS

    Login page does not appear on startng OEM

    DBelt
      I am trying to get OEM to run for a database installation that is less than a year old. The database is 11g running on Windows Server 2008R2. After installing it I was not able to get OEM to start up for me -- the login would not accept my credentials. I have been doing my account maintenance via sqlplus and I am just now getting around to get things working for OEM. After some delving, I learned to rebuild the Password File. I got that to work but the sysman password had expired since setting up the database. I have updated the password and the corresponding emoms.properties and the targets.xml files. Now, though, when I start up the OEM, the login page does not come up but instead opens to the Database Status page with the message:

      Enterprise Manager is not able to connect to the datase instance.

      The status displays for the various database components are as follows:

      Database Instance
      Status: Open
      Host: [correct hostname]
      Port: 1521
      SID: [correct sid verified via regedit]
      Oracle Home: [correct Oracle home directory verified via regedit]
      Details: The instance is open.

      Listener
      Status: Up
      Host: [correct hostname]
      Port: 1521
      Name: LISTENER
      Details: None

      Agent connection to instance
      Status: Succeeded
      Details: None

      According to the above information all should be well but it isn't.

      Any guesses?

      Edited by: DBelt on Apr 4, 2013 4:03 PM
        • 1. Re: Login page does not appear on startng OEM
          Loc Nhan -Oracle
          You should check log/trace files, especially emoms.trc, in directory <EM Home>/sysman/log for clues.

          - Loc
          • 2. Re: Login page does not appear on startng OEM
            DBelt
            The log and trace files end with notification that "The account is locked"

            There is no indication which account is locked. I have unlocked the sysman, dbsnmp, and system accounts, in sqlplus, and verified that they were unlocked by connecting to them using "connect" in sqlplus, previous to trying to open the EM. So I have no idea which account is locked, unless the accounts are being locked by something else. (?)
            • 3. Re: Login page does not appear on startng OEM
              DBelt
              Okay, I've done some more investigation.

              I logged into sqlplus as SYS AS SYSDBA
              Tried to connect to SYSMAN but the system responded with a message that the account is locked and then it disconnected my session.
              Connected back to the database via the command: CONNECT SYS AS SYSDBA
              Entered the password and connected successfully
              Unlocked the SYSMAN account via the command: ALTER USER SYSMAN ACCOUNT UNLOCK;
              Connected to the database successfully as SYSMAN
              Tried to open OEM: Opened directly to the Status display with out opening the login page
              Went back to sqlplus and tried connection as SYSMAN but the system said the account was locked
              Trace file emoms.trc also says the account is locked.

              So it does look like the attempt to open the OEM, or something else, is locking the sysman account
              • 4. Re: Login page does not appear on startng OEM
                Loc Nhan -Oracle
                It could be that DB Control and/or some other application were repeatedly trying to connect to the repository as user sysman without success causing the account to be locked.

                I suggest follow the steps in the following MOS note to change the sysman password for DB Control.

                How To Change the Password of the Database User Sysman (DB Control Repository Schema) (Doc ID 259379.1)

                - Loc
                • 5. Re: Login page does not appear on startng OEM
                  DBelt
                  This is exactly the information I needed. I notice two methods for changing the password one for DB version prior to 10.2 and one for 10.2 and later. I learned the procedures for those versions prior to 10.2 and was applying those to my 11.2 DB. The proper procedure worked exactly right and it is a much better process than the previous one.

                  Thank-you for the help.