7 Replies Latest reply: Apr 17, 2013 1:04 PM by 1001213 RSS

    Cannot install OEPE into STS 3.2.0

    1001213
      There is a dependency conflict from OEPE Spring Tools v2.2.1 to STS v3.2.0. Here is the message I get when trying to install:

      Cannot complete the install because of a conflicting dependency.
      Software being installed: Oracle Spring Tools 2.2.1.201303081427 (oracle.eclipse.tools.juno.spring.feature.group 2.2.1.201303081427)
      Software currently installed: Spring IDE Core (required) 3.2.0.201211290605-M1 (org.springframework.ide.eclipse.feature.feature.group 3.2.0.201211290605-M1)
      Only one of the following can be installed at once:
      Spring IDE Refactoring Support 3.3.0.201304042345-CI-B300 (org.springframework.ide.eclipse.beans.ui.refactoring 3.3.0.201304042345-CI-B300)
      Spring IDE Refactoring Support 3.2.0.201211290605-M1 (org.springframework.ide.eclipse.beans.ui.refactoring 3.2.0.201211290605-M1)
      Spring IDE Refactoring Support 3.1.0.201210040510-RELEASE (org.springframework.ide.eclipse.beans.ui.refactoring 3.1.0.201210040510-RELEASE)
      Spring IDE Refactoring Support 3.2.0.201302280838-RC2 (org.springframework.ide.eclipse.beans.ui.refactoring 3.2.0.201302280838-RC2)
      Cannot satisfy dependency:
      From: Oracle Spring Tools 2.2.1.201303081427 (oracle.eclipse.tools.juno.spring.feature.group 2.2.1.201303081427)
      To: org.springframework.ide.eclipse.feature.feature.group [3.1.0,3.2.0)
      Cannot satisfy dependency:
      From: Spring IDE Core (required) 3.1.0.201210040510-RELEASE (org.springframework.ide.eclipse.feature.feature.group 3.1.0.201210040510-RELEASE)
      To: org.springframework.ide.eclipse.beans.ui.refactoring [3.1.0.201210040510-RELEASE]
      Cannot satisfy dependency:
      From: Spring IDE Core (required) 3.2.0.201211290605-M1 (org.springframework.ide.eclipse.feature.feature.group 3.2.0.201211290605-M1)
      To: org.springframework.ide.eclipse.beans.ui.refactoring [3.2.0.201211290605-M1]

      It looks like OEPE has a hard dependency on Spring IDE 3.1.0.
        • 1. Re: Cannot install OEPE into STS 3.2.0
          Kosta-Oracle
          Each release of OEPE does integrate with one specific version of Spring IDE. If you need a newer version, you can choose not to install Oracle Spring Tools component.

          - Konstantin
          • 2. Re: Cannot install OEPE into STS 3.2.0
            1002643
            When I deselect the Oracle Spring Tools as I too am using STS 3.2.0, I get another error;

            Cannot complete the install because of a conflicting dependency.
            Software being installed: Oracle ADF Tools 2.2.1.201303081427 (oracle.eclipse.tools.juno.adf.feature.group 2.2.1.201303081427)
            Software currently installed: Graphical Editing Framework GEF SDK 3.9.0.201212170307 (org.eclipse.gef.sdk.feature.group 3.9.0.201212170307)
            Only one of the following can be installed at once:
            Graphical Editing Framework GEF 3.8.0.201206112118 (org.eclipse.gef 3.8.0.201206112118)
            Graphical Editing Framework GEF 3.8.1.201208201742 (org.eclipse.gef 3.8.1.201208201742)
            Graphical Editing Framework GEF 3.8.2.201301141834 (org.eclipse.gef 3.8.2.201301141834)
            Graphical Editing Framework GEF 3.9.0.201212170307 (org.eclipse.gef 3.9.0.201212170307)
            Cannot satisfy dependency:
            From: Oracle ADF Controller UI 5.2.1.201303081427 (oracle.eclipse.tools.adf.controller.ui 5.2.1.201303081427)
            To: bundle org.eclipse.gef [3.8.0,3.9.0)
            Cannot satisfy dependency:
            From: Oracle ADF Tools 2.2.1.201303081427 (oracle.eclipse.tools.juno.adf.feature.group 2.2.1.201303081427)
            To: oracle.eclipse.tools.adf.controller.ui [5.2.1.201303081427]
            Cannot satisfy dependency:
            From: Graphical Editing Framework GEF 3.9.0.201212170307 (org.eclipse.gef.feature.group 3.9.0.201212170307)
            To: org.eclipse.gef [3.9.0.201212170307]
            Cannot satisfy dependency:
            From: Graphical Editing Framework GEF SDK 3.9.0.201212170307 (org.eclipse.gef.sdk.feature.group 3.9.0.201212170307)
            To: org.eclipse.gef.feature.group [3.9.0.201212170307]
            • 3. Re: Cannot install OEPE into STS 3.2.0
              Kosta-Oracle
              It appears that STS 3.2, which is based on Eclipse 3.8.2 includes a pre-release build of GEF 3.9 from the Kepler release instead of GEF 3.8.2. I recommend reporting this issue to SpringSource.

              You may be able to workaround this issue by starting with an OEPE Eclipse distribution and installing STS component from their online repository (update site). This will start you with the correct version of GEF and hopefully STS 3.2 doesn't trip over that.

              - Konstantin
              • 4. Re: Cannot install OEPE into STS 3.2.0
                1001213
                Thanks Konstantin. This means that if you install OEPE, you cannot upgrade your Spring IDE. For example, I grabbed oepe-12.1.1.2.1-juno-distro-macosx-cocoa-x86_64.zip and tried to install STS 3.2.0 and could not.

                http:/dist.springsource.com/release/TOOLS/update/3.2.0.RELEASE/e4.2/

                This is unfortunate, but not a blocker. Is there any reason why OEPE includes a specific version of Spring IDE? Can it not be turned into a requirement instead of inclusion?

                And thanks for pointing out GEF 3.9. It should not be there. We will be looking at it for 3.3.0.M1. See here: https://issuetracker.springsource.com/browse/STS-3321
                • 5. Re: Cannot install OEPE into STS 3.2.0
                  Kosta-Oracle
                  Andrew Eisenberg wrote:
                  Is there any reason why OEPE includes a specific version of Spring IDE? Can it not be turned into a requirement instead of inclusion?
                  It is already a requirement, not an inclusion, but OEPE has plugins that integrate with Spring IDE API. By policy, those plugins declare dependency ranges that only allow service releases. More permissive version ranges are not an option as we would not be able to guarantee tooling stability across multiple feature-bearing releases where API shape and behavior can and does change.

                  - Konstantin
                  • 6. Re: Cannot install OEPE into STS 3.2.0
                    1001213
                    What API are you using and what additional features have you added?
                    • 7. Re: Cannot install OEPE into STS 3.2.0
                      1001213
                      I'm asking mostly because we weren't aware of others extending Spring IDE. And if we know how it is being extended, we will be more careful about API.