This discussion is archived
8 Replies Latest reply: Aug 6, 2013 2:09 AM by 912619 RSS

Details group not working in BIP

912619 Newbie
Currently Being Moderated
Hi,
Please help me solve this problem I am new in BIP. G_p group not displaying any record

<dataTemplate name="TEXT">
                    <properties>
                         <property name="xml_tag_case" value="upper"/>
                    </properties>
                    <lexicals>
                    </lexicals>
                    <dataQuery>
                         <sqlstatement name="Q_TEMP">
                              <![CDATA[SELECT DEPTNO,DNAME,LOC FROM DEPT]]>
                         </sqlstatement>
                         <sqlstatement name="Q_TEMP1">
                              <![CDATA[SELECT * FROM EMP WHERE DEPTNO = :DEPTNO]]>
                         </sqlstatement>
                    </dataQuery>
                    <datastructure>
                         <GROUP name="G_1" source="Q_TEMP">
                              <element name="DEPTNO" value="DEPTNO"/>
                              <element name="DNAME" value="DNAME"/>
                              <element name="LOC" value="LOC"/>
                              <GROUP name="G_2" source="Q_TEMP1">
                                   <element name="ENAME" value="ENAME"/>
                                   <element name="DEPTNP" value="DEPTNO"/>
                                   <element name="EMPNO" value="EMPNO"/>
                              </GROUP>
                         </GROUP>
                    </datastructure>
               </dataTemplate>
Kindly send solution this mail : yudhisthira.biswal@gmail.com

Thanks
Yudhi
  • 1. Re: Details group not working in BIP
    912619 Newbie
    Currently Being Moderated
    Hi,
    please help me for this problem.

    Thanks
  • 2. Re: Details group not working in BIP
    SunilSharma Expert
    Currently Being Moderated
    post ur question here(BIPublisher forum) BI Publisher you will get some quick response
  • 3. Re: Details group not working in BIP
    912619 Newbie
    Currently Being Moderated
    thanks for update

    i posted maintain link
    Details group not working in BIP

    plz look this issue.
  • 4. Re: Details group not working in BIP
    Srini VEERAVALLI Guru
    Currently Being Moderated
    Just in case the below statement be specific to the column names instead of *
    <![CDATA[SELECT * FROM EMP WHERE DEPTNO = :DEPTNO]]
    If helps mark
  • 5. Re: Details group not working in BIP
    912619 Newbie
    Currently Being Moderated
    Hi,
    Thanks your update now my report is working fine.

    Thanks
  • 6. Re: Details group not working in BIP
    Srini VEERAVALLI Guru
    Currently Being Moderated
    Can you mark as correct?
  • 7. Re: Details group not working in BIP
    912619 Newbie
    Currently Being Moderated
    Hi sirini,
    I am getting one error. Count and sum function not working proper.
    For example :
    Department 10 have 3 employee and total salary is 8750. But my report returning total employee 1 and total salary 5000
    10
    Ename Sal
    KING 5000
    CLARK 2450
    MILLER 1300
    ==================
    1     5000
    Kindly help me solve this problem.

    <dataTemplate name="TEXT">
                        <properties>
                             <property value="upper" name="xml_tag_case" />
                        </properties>
                        <lexicals>
                        </lexicals>
                        <dataQuery>
                             <sqlstatement name="Q_TEMP">
                                  <![CDATA[SELECT DEPTNO,DNAME,LOC FROM DEPT]]>
                             </sqlstatement>
                             <sqlstatement name="Q_TEMP1">
                                  <![CDATA[SELECT ENAME,HIREDATE,SAL FROM EMP WHERE DEPTNO = :DEPTNO]]>
                             </sqlstatement>
                        </dataQuery>
                        <datastructure>
                             <GROUP name="G_1" source="Q_TEMP">
                                  <element value="DEPTNO" name="DEPTNO" />
                                  <element value="DNAME" name="DNAME" />
                                  <element value="LOC" name="LOC" />
                                  <GROUP name="G_2" source="Q_TEMP1">
                                       <element value="ENAME" name="ENAME" />
                                       <element value="SAL" name="SAL" />
                                       <element value="G_2.ENAME" name="TOTL_DETAILS" dataType="number" function="COUNT()" />
                                       <element value="G_2.SAL" name="TOTL_SAL" function="SUM()"/>
                                  </GROUP>
                             </GROUP>
                        </datastructure>
                   </dataTemplate>


    Thanks
    Yudhi
  • 8. Re: Details group not working in BIP
    912619 Newbie
    Currently Being Moderated

    Hi sirini,

    I have one requirement display the customer image in BIP report?

    1. We are storing the image in one server and image name inserted in Database
    2. In XML I am selecting customer details with image name . for same image name I want customer image in BIP report

     

    Kindly help me display the customer image in BIP report.

    If u have any example mail me : Yudhisthira.biswal@gmail.com

     

    Thanks

    Yudhi

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points