8 Replies Latest reply on Apr 9, 2013 5:46 PM by 986571

    Unable to Login OAMCONSOLE after fresh installation

    941300
      Hi Expert,

      I have done fresh installation of IDM Stack. I am unable to login to oamconsole. I try giving default weblogic user name and password but nothing is happening.

      Same weblogic username is working for weblogic/em server. I am unable to identify the causes begind it, please help.

      while googling come to know it may be coz of IPV6 hence i even tried to disable it as follow.
      1. I had already made following entries in ifcfg-eth0 :
      IPv6INIT=NO
      IPV6AUTOCONF=NO
      2. Following entries were made in /etc/modprob.conf” :
      alias net-pf-10 off
      alias ipv6 off
      3. These entries in /etc/sysconfig/network :
      IPV6INIT=NO
      NETWORKING_IPV6=NO
      4. This line is added to /etc/modprobe.d/blaclist :
      blacklist ipv6
      5. Also I did one more in /etc/sysctl.conf :
      6. `net.ipv6.conf.all.autoconf = 0`
      7. `net.ipv6.conf.accept_ra = 0`

      I have also Change the domain configuration settings (edit the setDomainEnv file to disable to IPV6 properties)

      set EXTRA_JAVA_PROPERTIES=%EXTRA_JAVA_PROPERTIES% -Didm.oracle.home=%IDM_ORACLE_HOME% -Xms512m -Xmx1024m -Xss512K -Djava.net.preferIPv6Addresses=false -DuseIPv6Address=false -Djava.protocol.handler.pkgs=oracle.mds.net.protocol -Dweblogic.management.discover=false -Djava.net.preferIPv6Addresses=false

      set EXTRA_JAVA_PROPERTIES=%EXTRA_JAVA_PROPERTIES% -DDomain.home=%Domain_HOME% -Xms512m -Xmx1024m -Xss512K -Djava.net.preferIPv6Addresses=false -DuseIPv6Address=false -Djava.protocol.handler.pkgs=oracle.mds.net.protocol -Dweblogic.management.discover=false -Djava.net.preferIPv6Addresses=false

      set EXTRA_JAVA_PROPERTIES=%EXTRA_JAVA_PROPERTIES% -Doam.oracle.home=%oam_ORACLE_HOME% -Xms512m -Xmx1024m -Xss512K -Djava.net.preferIPv6Addresses=false -DuseIPv6Address=false -Djava.protocol.handler.pkgs=oracle.mds.net.protocol -Dweblogic.management.discover=false -Djava.net.preferIPv6Addresses=false
        • 1. Re: Unable to Login OAMCONSOLE after fresh installation
          ColinPurdon-Oracle
          Hi,

          Do you see any exceptions in OAM's AdminServer log (or diagnostic log) file? Also, are you seeing this behaviour when only the Admin Server is running, or are you also running an OAM managed server?

          Regards,
          Colin
          • 2. Re: Unable to Login OAMCONSOLE after fresh installation
            941300
            Hi Colin,

            When I have only Admin Server running & try to access oamconsole url it gies below error

            ==> AdminServer-diagnostic.log <==
            [2013-04-08T23:15:43.062+10:00] [AdminServer] [ERROR] [] [] [tid: [ACTIVE].ExecuteThread: '4' for queue: 'weblogic.kernel.Default (self-tuning)'] [userId: <anonymous>] [ecid: 11d1def534ea1be0:86a09f8:13de9c43aca:-8000-0000000000000046,0] [APP: oam_admin#11.1.2.0.0] Failed to communicate with any of configured Access Server, ensure that it is up and running.
            ==============================================================================
            runnig oam managed server does not give any difference nor give any error in the log. oam managed runn successfully.

            I even created user in weblogic & tried to access oamconsole but nothing is happening.

            Note: its just a plain 11gR2 installation, I am able to login all other component ODSM,OIM,SOA etc

            while starting oam managed server i can see below error (according to google it can be ignored) but i dont think anyway oamconsole login has to do with oam at this stage?
            ====================================================================================
            oam_server.log

            <<WLS Kernel>> <> <0000Jr_LDRiFw000jzwkno1HOPvN000002> <1365352206231> <BEA-101216> <Servlet: "AMInitServlet" failed to preload on startup in Web application: "oam
            ".
            java.lang.ExceptionInInitializerError
            at oracle.security.am.engines.sso.adapter.SessionManagementAdapterFactory.getAdapter(SessionManagementAdapterFactory.java:46)
            at oracle.security.am.engines.enginecontroller.SSOEngineController.processEvent(SSOEngineController.java:548)
            at oracle.security.am.controller.MasterController.processEvent(MasterController.java:570)
            at
            at weblogic.t3.srvr.SubsystemRequest.run(SubsystemRequest.java:64)
            at weblogic.work.SelfTuningWorkManagerImpl$WorkAdapterImpl.run(SelfTuningWorkManagerImpl.java:545)
            at weblogic.work.ExecuteThread.execute(ExecuteThread.java:256)
            at weblogic.work.ExecuteThread.run(ExecuteThread.java:221)
            Caused By: oracle.security.am.common.utilities.exception.AmRuntimeException: OAMSSA-10004
            at oracle.security.am.engines.sso.adapter.AbstractSessionAdapterImpl.throwInitializationException(AbstractSessionAdapterImpl.java:131)
            at oracle.security.am.engines.sso.adapter.MultipleUserSessionAdapterImpl.<clinit>(MultipleUserSessionAdapterImpl.java:47)
            at oracle.security.am.engines.sso.adapter.SessionManagementAdapterFactory.getAdapter(SessionManagementAdapterFactory.java:46)
            More(60%)

            at weblogic.work.ExecuteThread.run(ExecuteThread.java:221)
            Caused By: oracle.security.am.engines.sme.exceptions.ManagerNotCreatedException: OAMSSA-02008: Cannot instantiate the persistence access implementation for class Per
            sistedSessionCache.
            at oracle.se
            ===========================================================================================
            2)oam_server-dignostic.log
            Default (self-tuning)'] [userId: <anonymous>] [ecid: 0000Jr_LDRiFw000jzwkno1HOPvN000002,0] [APP: oam_server#11.1.2.0.0] The exception has been thrown by ARME. The au
            thorization result is set to deny.[[
            com.bea.security.providers.authorization.asi.InvocationException: ArmeRUNTIME Exception: null
            at com.bea.security.providers.authorization.asi.AuthorizationProviderImpl.isAccessAllowed(AuthorizationProviderImpl.java:396)
            at com.bea.security.ssal.micro.MicroAuthorizationManagerWrapper.isAccessAllowed(MicroAuthorizationManagerWrapper.java:73)
            at co
            =========================================================================

            I also notice that when i see in WL> deployment>oam_server (11.1.2.0.0) state is failed.
            Help Appreciated

            Edited by: IgnitedMind on 8/04/2013 06:44

            Edited by: IgnitedMind on 8/04/2013 09:16
            • 3. Re: Unable to Login OAMCONSOLE after fresh installation
              delhi
              Can you check if you have sufficient permission on /tmp/* directory

              Regards,
              Sunny
              • 4. Re: Unable to Login OAMCONSOLE after fresh installation
                941300
                Hi Sunny,

                Thanks for the promt response.

                Yes I have sufficient permission on /tmp/*

                Still unable to logion oamconsole with any weblogic user :(
                • 5. Re: Unable to Login OAMCONSOLE after fresh installation
                  ColinPurdon-Oracle
                  Not sure what to suggest, it is not a good sign that oam_server has failed deployment. How about the oam-admin ? If it is also in a failure state, you could try to re-deploy it and see what messages you get. Also, in the WebLogic /console, look at the authentication providers, and verify that DefaultAuthenticator is enabled, and that none of the others are REQUIRED.

                  Regards,
                  Colin
                  • 6. Re: Unable to Login OAMCONSOLE after fresh installation
                    941300
                    oam_admin is active state. I have removed IAMSuiteAgent and OIMAuthenticationProvider.hence now have only two default provider
                    1)DefaultAuthenticator as required 2)DefaultIdentityAsserter
                    Why still not able to login to oamconsole ? Do you think any other alternate way to overcome this prob,please

                    Also oam_server is in Failed state even after redeploy the ear.

                    Edited by: IgnitedMind on 9/04/2013 09:36
                    • 7. Re: Unable to Login OAMCONSOLE after fresh installation
                      delhi
                      Hi,

                      I know you have disabled IPV6 and if you haven't run the below code, then please try it:

                      import java.net.*;
                      import java.util.*;
                      public class IPV4Only {
                      public static void main(String[] args) throws Exception {
                      boolean b=true;
                      Enumeration<NetworkInterface> nifs = NetworkInterface.getNetworkInterfaces();
                      while (nifs.hasMoreElements()) {
                      NetworkInterface nif = nifs.nextElement();
                      Enumeration<InetAddress> addrs = nif.getInetAddresses();
                      while (addrs.hasMoreElements()) {
                      InetAddress hostAddr = addrs.nextElement();
                      if ( hostAddr instanceof Inet6Address ){
                      b=false;
                      System.out.println("NetworkInterfaceV6List failed - found IPv6 address " + hostAddr.getHostAddress() );
                      }
                      }
                      }
                      if (b) {
                      System.out.println("No IPv6 detected");
                      } else {
                      System.out.println("Detect IPv6 interfaces - use java property java.net.preferIPv4Stack=true ");
                      }
                      }
                      }

                      and share the output

                      Regards,
                      Sunny
                      • 8. Re: Unable to Login OAMCONSOLE after fresh installation
                        986571
                        Hi,

                        I had some login issue on installing OAM on Windows server and setting WLSAGENT_DISABLED to true in the environment vairiable fixed the issue.

                        Regards