4 Replies Latest reply: Apr 10, 2013 10:54 AM by Eric Sacramento RSS

    OC4J + APEX 4.1 + APEX LISTENER

    Eric Sacramento
      Hi all,

      Firstly, I dont know if I have to open another topic, but I think I should write here! Otherwise sorry about that!

      I've been facing the problem since yesterday, I tried a lot of things....

      Here you can find my variable:

      APEX_HOME C:\apex_4.1.1_en\apex

      J2EE_HOME C:\oc4j_extended_101350\j2ee\home

      JAVA_HOME C:\Program Files\Java\jdk1.7.0_01

      ORACLE_SID XE

      PATH C:\oraclexe\app\oracle\product\11.2.0\server\bin;C:\Program Files (x86)\ATI Technologies\ATI.ACE\Core-Static;C:\ant\bin;C:\Program Files\Java\jdk1.7.0_01\bin

      ORACLE_HOME C:\oc4j_extended_101350

      C:\oraclexe\app\oracle\product\11.2.0\server

      If I put in ORACLE_HOME just C:\oc4j_extended_101350 only OC4J will work BUT if I change it for C:\oraclexe\app\oracle\product\11.2.0\serve just APEX will work.

      What should I do ? I am using Windows 7, Oracle Database 11g Express Edition !

      Thank you!
        • 1. Re: OC4J + APEX 4.1 + APEX LISTENER
          Udo
          Hi Eric,
          If I put in ORACLE_HOME just C:\oc4j_extended_101350 only OC4J will work BUT if I change it for C:\oraclexe\app\oracle\product\11.2.0\serve just APEX will work.

          What should I do ? I am using Windows 7, Oracle Database 11g Express Edition !
          How do you run your OC4J? If you start it on demand, create a wrapper batch script to reset ORACLE_HOME for that start only, don't touch the global environment variable for your database, e. g.
          SET JAVA_HOME=C:\Program Files\Java\jdk1.7.0_01
          SET ORACLE_HOME=C:\oc4j_extended_101350
          "%ORACLE_HOME%"\bin\oc4j.cmd -start
          If you start it as windows service, try to create a separate account for it and set a user specific ORACLE_HOME instead of a global one.

          -Udo
          • 2. Re: OC4J + APEX 4.1 + APEX LISTENER
            Eric Sacramento
            Hi Udo,

            I run OC4J manually.

            Witch one is correct ?

            1 SET ORACLE_HOME=C:\oc4j_extended_101350"%ORACLE_HOME%"\bin\oc4j.cmd -start
            2 SET ORACLE_HOME=C:\oc4j_extended_101350%ORACLE_HOME%\bin\oc4j.cmd -start
            3 SET ORACLE_HOME=C:\oc4j_extended_101350 %ORACLE_HOME%\bin\oc4j.cmd -start

            I used number 3

            Now, OC4J is not working!

            Thank you for helping me,
            Eric
            • 3. Re: OC4J + APEX 4.1 + APEX LISTENER
              Udo
              Hi Eric,
              I run OC4J manually.
              Okay, so the supplied snippet should be all you need.
              Witch one is correct ?

              1 SET ORACLE_HOME=C:\oc4j_extended_101350"%ORACLE_HOME%"\bin\oc4j.cmd -start
              2 SET ORACLE_HOME=C:\oc4j_extended_101350%ORACLE_HOME%\bin\oc4j.cmd -start
              3 SET ORACLE_HOME=C:\oc4j_extended_101350 %ORACLE_HOME%\bin\oc4j.cmd -start
              None. Setting the environment variable ORACLE_HOME and starting OC4J with reference to that variable are two separate, successive steps. My snippet above shows three lines. You need all three in appropriate order in your batch file to get your oc4j started properly.

              -Udo
              • 4. Re: OC4J + APEX 4.1 + APEX LISTENER
                Eric Sacramento
                It worked !! Thanks a lot ! :D

                Edited by: Eric Sacramento on 10 avr. 2013 08:54