This discussion is archived
1 2 Previous Next 15 Replies Latest reply: Apr 12, 2013 1:30 PM by EdStevens RSS

second layer of runInstaller GUI could not be shown correctly on PC.

946717 Newbie
Currently Being Moderated
- Here is the issue. I have set DISPLAY variable on the server, Oralce linux 6.3, and able to launch runInstaller GUI on my desktop without a problem. However, if I continue on configurations, when second window is needed, it just could not be correctly shown on my PC. I can see the window frame, but, the contents got blank out. For instance, if i click "cancel" buttom, the 2nd small window comes up, it is supposed to ask me for the confirmation, the problem is that I couuld not see or click the confirmation.

- I tried Exceed, vnc, or xterm, the issue is the same.

- i tried different PC, same issue.

I can not exit out from PC, and have to kill the process on the server.


Need Help, please!
  • 1. Re: second layer of runInstaller GUI could not be shown correctly on PC.
    rukbat Guru Moderator
    Currently Being Moderated
    Moderator Action:
    This post has been moved out of the Oracle Linux forum,
    to the Exadata forum where you have all your other recent posts dealing with the installation/startup/shutdown processes you're going through.

    Example thread:
    wanted to shutdown all Exadata db nodes, Do  I need to do anything on cells

    A suggestion?
    Don't install through a remote GUI. Try text mode.
  • 2. Re: second layer of runInstaller GUI could not be shown correctly on PC.
    946717 Newbie
    Currently Being Moderated
    Hi rukbat ,

    these two are totaly different issue. the other is about shutdown/reboot. This one is about running runInstaller and display GUI on my PC's. I am trying to do this on a single alone server, and has nothing to do with Exadata.
    I could not use text mode, since runInstaller is commonly used tool, and we like to get it work.

    Would you please post this message here on Oracle linux forum?

    Thanks!
  • 3. Re: second layer of runInstaller GUI could not be shown correctly on PC.
    rukbat Guru Moderator
    Currently Being Moderated
    Ok.
    ... moved back to the Oracle Linux forum.
  • 4. Re: second layer of runInstaller GUI could not be shown correctly on PC.
    BillyVerreynne Oracle ACE
    Currently Being Moderated
    Sounds like an X-server/environment issue of sorts.

    What X-server are you using? twm? Gnome?

    What fonts are installed?

    What are the command line parameters passed to the installer (if any)?

    The installer is Java, right (you did not mention exactly what product you are installing)? How sane is your installation session environment ito using the correct Java libraries for rendering?

    Have you tried isolating the problem by testing other X software (like xeyes, calculator, calender, etc) to determine whether these display readable windows?

    What does the installer's log file say? These are usually pretty verbose and useful for troubleshooting installer issues.
  • 5. Re: second layer of runInstaller GUI could not be shown correctly on PC.
    946717 Newbie
    Currently Being Moderated
    I tried "xclock" and "xeyes". those tools are working fine, i will have the problem only if there any required second layer sub-gui coming up.
    I am using Exceed as the client to accept X gui, using putt to log into the server first, then export DISPLAY variable, then run runInstaller, the display will come to my desktop, but if there are any 2nd layer small window, then I am not able to see or click on the second layer window.

    X window package is installed. I am running runInstaller to install Oralce database, I did not even start with any configurations, not using any options, only runInstaller.
  • 6. Re: second layer of runInstaller GUI could not be shown correctly on PC.
    946717 Newbie
    Currently Being Moderated
    in the log file which is located on the server, I am getting quite a lot of messages complaing about Exceed fondts. Are there anything I need to do with Exceed on the PC? not sure of if this is an issue..

    _FontTransOpen: Unable to Parse address C:/Program Files/Hummingbird/Connectivity/13.00/Exceed/Font/misc
    Could not init font path element C:/Program Files/Hummingbird/Connectivity/13.00/Exceed/Font/misc, removing from list!
    _FontTransOpen: Unable to Parse address C:/Program Files/Hummingbird/Connectivity/13.00/Exceed/Font/100dpi
    Could not init font path element C:/Program Files/Hummingbird/Connectivity/13.00/Exceed/Font/100dpi, removing from list!
  • 7. Re: second layer of runInstaller GUI could not be shown correctly on PC.
    Dude! Guru
    Currently Being Moderated
    Does it work when you run Windows in safe mode with networking?
  • 8. Re: second layer of runInstaller GUI could not be shown correctly on PC.
    EdStevens Guru
    Currently Being Moderated
    943714 wrote:
    I tried "xclock" and "xeyes". those tools are working fine, i will have the problem only if there any required second layer sub-gui coming up.
    I am using Exceed as the client to accept X gui, using putt to log into the server first, then export DISPLAY variable, then run runInstaller, the display will come to my desktop, but if there are any 2nd layer small window, then I am not able to see or click on the second layer window.

    X window package is installed. I am running runInstaller to install Oralce database, I did not even start with any configurations, not using any options, only runInstaller.
    Between this and your next message regarding the Exceed fonts, this sounds almost exactly like a problem I had a few weeks ago, only using xMing instead of Exceed. I don't remember the exact steps to fix, but it involved poking around on the net looking for some xMing fonts to install. Looks like you need to do the same for Exceed.

    BTW, you do realize Exceed costs a bundle of money while xMing is free ... if all you need is a lightweight x-server. You are already using PuTTY (I assume "putt" was just a typo) for your ssh client, so what is Exceed giving you for your money?
  • 9. Re: second layer of runInstaller GUI could not be shown correctly on PC.
    946717 Newbie
    Currently Being Moderated
    Hi Dude,

    Just tried that, safe mode without networking. No luck, the same.

    EDStevens,

    I understand what you are saying, but Exceed is our standard here, I have other users and they are using it as well. I still need to fix it.

    It sounds weird...

    any other suggestion?
  • 10. Re: second layer of runInstaller GUI could not be shown correctly on PC.
    Avi Miller Guru
    Currently Being Moderated
    943714 wrote:
    For instance, if i click "cancel" buttom, the 2nd small window comes up, it is supposed to ask me for the confirmation, the problem is that I couuld not see or click the confirmation.
    Make sure you have at least the tiny window manager installed: xorg-x11-twm. I know this is needed for window management via VNC. I suspect it may be useful for X11 forwarding as well.
  • 11. Re: second layer of runInstaller GUI could not be shown correctly on PC.
    Dude! Guru
    Currently Being Moderated
    Before re-installing or installing any additional software I suggest to make sure you are not running into compatibility issues with your video card and advanced rendering options. The results are typically missing or blank windows and buttons. I have seen this before with the Java based runInstaller.

    Windows in Save mode should take have care of rendering compatibility issues on the PC side. Regarding VNC, how are you using it? e.g. GNOME remote desktop sharing or VNC server? If the problem occurs under GNOME or VNC using GNOME remote desktop sharing, verify you have Visual Effects disabled in the System:Preferences:Appearance control panel.

    Exceed has problems on it's own. You might want to verify it is using the "native" window manager and does not do any fancy window decorating. Last not least there are many ways to use X11. The XDMCP protocol and setting the DISPLAY variable are obsolete. If you use SSH with X Forwarding, you should not set the DISPLAY variable.

    Troubleshooting X Windows can be quite complex. Please describe exactly what you are doing to avoid the guesswork and also what product you are trying to install. And last, not least, can you be sure that your installation source is not corrupted or bad?
  • 12. Re: second layer of runInstaller GUI could not be shown correctly on PC.
    BillyVerreynne Oracle ACE
    Currently Being Moderated
    My suggestion is to install twm, xterm and tigervnc-server (not installed by default on Linux 6).

    Run vncserver. Specify a password.

    Use vncviewer (I prefer tightvnc) on Windows to connect.

    Did exactly this last night, building a new Oracle db server on Linux 6 in the office, from my Win7 home PC. Running Grid Infrastructure's installer for setting up ASM via vnc. Worked without any problems.
  • 13. Re: second layer of runInstaller GUI could not be shown correctly on PC.
    EdStevens Guru
    Currently Being Moderated
    943714 wrote:
    Hi Dude,

    Just tried that, safe mode without networking. No luck, the same.

    EDStevens,

    I understand what you are saying, but Exceed is our standard here, I have other users and they are using it as well. I still need to fix it.
    I understand that. My question about why Exceed was just a side observation. My main point was the parallel between your error with Exceed and my error with xMing. Is it possible that there is a font set for Exceed that you need to install?
    >
    It sounds weird...

    any other suggestion?
  • 14. Re: second layer of runInstaller GUI could not be shown correctly on PC.
    946717 Newbie
    Currently Being Moderated
    finally, I give Exceed up. I got Xming installed, and that resolved the issue. Thank you all!
    got the idea about using Xming from EdStevens
1 2 Previous Next

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points