2 Replies Latest reply: Apr 15, 2013 3:34 AM by 1002680 RSS

    Separator for the feed file

    1002680
      Hi All,

      I am using DRM version 11.1.2.2. I am getting a comma separated file from the source to import in DRM. The data in file also have comma as a value which is shown as below:

      Parent, Child, Description
      P1, C1, Child1 Description
      P1, C2, *“Child2, Description”*
      P3, C3, Child3 Description


      So for the line 2 of data, DRM reads it a four columns instead of three and give error ‘Line does not contain same number of columns’.
      The easy solution is to get some other separator as pipe (|) or tilde (~) from the source instead of comma. But problem is that even these characters may come from source as Description.
      Is there a way I can define to ignore special character inside quotes.

      Thanks for your response.
        • 1. Re: Separator for the feed file
          Singh_Shashank
          Hi,

          Try to import by checking the option "Strip Quotation Marks".

          Hope this helps

          Thanks
          • 2. Re: Separator for the feed file
            1002680
            Thanks for your reply, but it is not solving the problem.

            Selecting 'Strip Quotation mark' will remove double quotes (") before the Child2 and after Description of the line. Hence there is extra comma now in _Child2, Description_.

            There are 3 columns mapped in the import process but DRM assumes that four are coming from the source. Below is the interpretation :-

            P1, C1, Child1 Description
            P2, C2, Child2 , Description

            Edited by: user1116391 on Apr 15, 2013 1:34 AM