This discussion is archived
6 Replies Latest reply: Apr 13, 2013 1:33 PM by KonradZuse RSS

JavaFX 8 on Ubuntu no longer working

1002807 Newbie
Currently Being Moderated
I installed Java 8 on my Ubuntu 12.10 x64 machine and it worked fine about a week ago. However, recently I can't run anything that even imports JavaFX namespaces, because I always get this error:

Caused by: java.lang.NullPointerException
     at com.sun.javafx.tk.quantum.QuantumToolkit.isSupported(QuantumToolkit.java:1227)
     at com.sun.javafx.application.PlatformImpl.isSupported(PlatformImpl.java:447)
     at com.sun.javafx.application.PlatformImpl$10.run(PlatformImpl.java:527)
     at java.security.AccessController.doPrivileged(Native Method)
     at com.sun.javafx.application.PlatformImpl.setPlatformUserAgentStylesheet(PlatformImpl.java:522)
     at com.sun.javafx.application.PlatformImpl.setDefaultPlatformUserAgentStylesheet(PlatformImpl.java:474)
     at javafx.scene.control.Control.<clinit>(Control.java:82)

Was there an update recently that might have caused this, or something else?
  • 1. Re: JavaFX 8 on Ubuntu no longer working
    KonradZuse Explorer
    Currently Being Moderated
    Honestly there are a lot of errors going around with builds and 8. I personalyl had issues with 81-83, where 84 now fixed the issue.

    It's weird that you are having an issue with a beta build THAT WORKED initially, and now doesn't.


    The Java 8 beta builds are not edited, so no it's not that.


    Imo I would uninstall and reinstall Java 8.

    http://jdk8.java.net/


    Also I would check your path to JDK 8, as sometimes you might be looking at Java 7 and 8 at the same time, or might not be looking at 8 at all.
  • 2. Re: JavaFX 8 on Ubuntu no longer working
    1002807 Newbie
    Currently Being Moderated
    Yeah I've tried completely uninstalling but I get the same error after reinstalling. I am on build 84, but I'm not sure if I was last week. It definitely worked when I used it then; I was able to fire up a window with various controls on it. I don't really understand what the stylesheet stuff is about...I am not doing anything related to CSS in my code.

    $ java -version
    java version "1.8.0-ea"
    Java(TM) SE Runtime Environment (build 1.8.0-ea-b84)
    Java HotSpot(TM) 64-Bit Server VM (build 25.0-b25, mixed mode)
  • 3. Re: JavaFX 8 on Ubuntu no longer working
    shakir.gusaroff Expert
    Currently Being Moderated
    In Netbeans go to Project Properties --> Libraries --> Compile and make sure it is pointing to java1.8
  • 4. Re: JavaFX 8 on Ubuntu no longer working
    1002807 Newbie
    Currently Being Moderated
    I figured out the problem -- I was, as I suspected, using an older build last week. Since I installed Java 8 via the webupd8 repository [1], my system was automatically updated when they pushed build 84 out. I found their previous version, build 78, as a .deb file [2], and installed it manually. I am now back on build 78 and things are working fine. Hopefully this issue will be fixed in a later build soon, so I can go back to the latest version available.

    [1] http://www.webupd8.org/2012/09/install-oracle-java-8-in-ubuntu-via-ppa.html
    [2] https://launchpad.net/~webupd8team/+archive/java/+sourcepub/3004224/+listing-archive-extra
  • 5. Re: JavaFX 8 on Ubuntu no longer working
    jsmith Guru
    Currently Being Moderated
    Perhsps you encountered this NetBeans issue (or something related to it):

    javafx platform is not correctly defined "javafx platform is not correctly defined"
  • 6. Re: JavaFX 8 on Ubuntu no longer working
    KonradZuse Explorer
    Currently Being Moderated
    I'm still not too sure why there are builds on Netbeans 7.3, when they have Lambda8 working (Or is it for lambda8 since the installer is different from the one I have).

    It seems that these nightly builds have been causing issues for people... Not too sure why there are 2 sets of beta builds running :(.

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points