1 Reply Latest reply: Apr 19, 2013 3:09 AM by 708594 RSS

    OCFS2 on Oracle Linux 6.4

    708594
      Hi there,
      I'm trying to setup a clustered filesystem on a iSCSI SAN using ocfs on oracle linux 6.4 (+Linux ha-node01 2.6.39-400.21.1.el6uek.x86_64 #1 SMP Thu Apr 4 03:49:00 PDT 2013 x86_64 x86_64 x86_64 GNU/Linux+).

      I installed the ocfs2-tools from oracle public yum repository and configured /etc/ocfs2/cluster.conf as follows:

      node:*
      name = node01*
      cluster = ocfs2*
      number = 0*
      ip_address = 10.0.0.1*
      ip_port = 7777*

      node:*
      name = node02*
      cluster = ocfs2*
      number = 1*
      ip_address = 10.0.0.2*
      ip_port = 7777*

      cluster:*
      name = ocfs2*
      heartbeat_mode = local*
      node_count = 2*

      Kernel modules seems to have been loaded correctly, nodes can ping each other even using names (node01 and node02), but there's no way to get cluster up and the strange thing is that there's no o2net daemon listening on port 7777. Obviously, I'm not able to mount any ocfs2 filesystem.

      Here's a snippet of what happens:

      *+[root@ha-node01 ~]# service o2cb start+*
      Loading filesystem "configfs": OK*
      Mounting configfs filesystem at /sys/kernel/config: OK*
      Loading stack plugin "o2cb": OK*
      Loading filesystem "ocfs2_dlmfs": OK*
      Mounting ocfs2_dlmfs filesystem at /dlm: OK*
      Setting cluster stack "o2cb": OK*
      Registering O2CB cluster "ocfs2": OK*
      Setting O2CB cluster timeouts : OK*

      *+[root@ha-node01 ~]# service o2cb status+*
      Driver for "configfs": Loaded*
      Filesystem "configfs": Mounted*
      Stack glue driver: Loaded*
      Stack plugin "o2cb": Loaded*
      Driver for "ocfs2_dlmfs": Loaded*
      Filesystem "ocfs2_dlmfs": Mounted*
      Checking O2CB cluster "ocfs2": Offline*

      *+[root@ha-node01 ~]# ps ax | grep o2net+*
      +2580 pts/0    S+     0:00 grep o2net+
      *+[root@ha-node01 ~]#+*

      *+[root@ha-node01 ~]# lsmod+*
      Module                  Size  Used by*
      ocfs2_dlmfs            20160  1*
      ocfs2_stack_o2cb        4103  0*
      ocfs2_dlm             228412  1 ocfs2_stack_o2cb*
      ocfs2_nodemanager     219951  9 ocfs2_dlmfs,ocfs2_stack_o2cb,ocfs2_dlm*
      ocfs2_stackglue        11896  2 ocfs2_dlmfs,ocfs2_stack_o2cb*
      configfs               29244  2 ocfs2_nodemanager*


      What can I do in order to troubleshoot this issue?
      Maybe there are some problems with the new 6.4 release of OL6 ?

      Thanks

      Edited by: user5144844 on 18-apr-2013 23.59