5 Replies Latest reply: Apr 21, 2013 3:16 PM by altF4 RSS

    Content item not added to a Folder

    altF4
      Hello all.

      I am using Framework Folders component and have a problem with adding content to a folder.

      When I try to add item to a folder from browsed folders page (Add -> New Content Item) it opens popup check in page, after checking in content i'm getting Check-In Confirmation page.
      It does not automatically add document in a folder.

      -     Link New content item calls idc.folders.showCreateFilePopup and it passes folderGUID and currentPath to popup window.
           http://ucm:16200/cs/idcplg?isPopup=1&coreContentOnly=1&fFileType=owner&fParentGUID=84F9CE86A4FB9F6872ED1FF9EE2E29B4&IdcService=CHECKIN_NEW_FORM
      -     But on check in page I’m missing fParentGUID field.

      This is copy/paste from frameworkfolders_dynhtml.idoc
      <!-- fParentGUID field shown on the checkin page -->
      <@dynamichtml fld_checkin_new_form_fields@>
           <$exec ddLoadResultSet("FldCheckinFieldIncludes", "checkinFields")$>
           <$exec ddMergeUsingIndexedKey("FldFieldIncludes", "checkinFields", "fFieldName")$>
           <$exec rsCreateReference("checkinFields", "fldTmpRset")$>
           <$include fld_filter_field_includes$>
           <$exec rsRemove("fldTmpRset")$>
           <$if isPopup or (not isNew and not isUpdate)$>
                <$setValue("#local", "fParentGUID:isReadOnly", "1")$>
                <$setValue("#local", "fParentGUID_display:isReadOnly", "1")$>
           <$endif$>
           <$setValue("#local", "fParentGUID:isRequired", "0")$>
           <$setValue("#local", "fParentGUID_display:isRequired", "0")$>
           <$setValue("#local", "fParentGUID:browsePopupExtraParams", "'foldersFilterParams':'fIsContribution', 'fIsContribution':'1'")$>
           <$include fld_checkin_new_form_fields_internal$>
      <@end@>

      If you can suggest me some approach that will be very helpful.

      Edited by: altF4 on Apr 19, 2013 6:00 AM
        • 1. Re: Content item not added to a Folder
          Jiri.Machotka-Oracle
          When I try to add item to a folder from browsed folders page (Add -> New Content Item) it opens popup check in page, after checking in content i'm getting Check-In Confirmation page.
          a) do you see the folder (not the parent folder) filled in on the CHECKIN_NEW_FORM?
          (If not - for instance, it uses a profile where this field is hidden, read-only or uses the default value - that could explain it).

          b) what happens if you use Standard Check-in and fill in the folder manually?

          c) how does this behave from DIS?
          (you could compare what requests are called)
          • 2. Re: Content item not added to a Folder
            altF4
            Jiri, thanks for the reply.
            jiri.machotka wrote:
            a) do you see the folder (not the parent folder) filled in on the CHECKIN_NEW_FORM?
            (If not - for instance, it uses a profile where this field is hidden, read-only or uses the default value - that could explain it).
            No, I don't see folder field on checkin popup window.
            I also thought that profiles might make some mess so I deleted all profiles and I don't have any rule set as global.
            jiri.machotka wrote:
            b) what happens if you use Standard Check-in and fill in the folder manually?
            It also doesn't show any folder fields.
            Should I have any Information field in Configuration Manager in Component column marked as FrameworkFolders?
            jiri.machotka wrote:
            c) how does this behave from DIS?
            (you could compare what requests are called)
            It works perfectly from DIS.
            • 3. Re: Content item not added to a Folder
              Jiri.Machotka-Oracle
              I think the answer is available here: FrameWork Folder Documentation and especially http://jonathanhult.com/blog/2012/10/hide-folder-field-in-11g-folders/
              • 4. Re: Content item not added to a Folder
                user434745
                This should work.

                Can you find the item you checked in with an open search? Try that and then, if you find it, look on the item's doc info page for the folder path (at the bottom of the doc info page).

                If the "View" setting for the folder is "Published items" instead of "All items", it may just be due to the indexing delay that you can't see it the item in the folder browse page, right away.
                • 5. Re: Content item not added to a Folder
                  altF4
                  Thank you guys!

                  Both answers were really helpful.