3 Replies Latest reply: Apr 24, 2013 9:58 AM by clcarter RSS

    XE Installation error

      I'm trying to install XE but i receive this error: opiino: Attach failed due to ORA-12638

      Can you help me?


      One of the trc file says
      "Dump file c:\oraclexe\app\oracle\product\11.2.0\server\rdbms\trace\xe_ora_1240.trc
      Tue Apr 23 18:19:37 2013
      ORACLE V11. - Production vsnsta=0
      vsnsql=16 vsnxtr=3
      Oracle Database 11g Express Edition Release - Production
      Windows NT Version V6.0 Service Pack 2
      CPU : 2 - type 586, 2 Physical Cores
      Process Affinity : 0x0x00000000
      Memory (Avail/Total): Ph:3033M/4095M, Ph+PgF:6859M/8451M, VA:1807M/2047M
      VM name : VMWare Version (6)

      Instance name: xe

      Redo thread mounted by this instance: 0 <none>

      Oracle process number: 0

      Windows thread id: 1240, image: ORACLE.EXE (SHAD)

      *** 2013-04-23 18:19:37.540

      opiino: Attach failed due to ORA-12638 "
        • 1. Re: XE Installation error
          Quoting from the error message docs ...
          ORA-12638: Credential retrieval failed
              Cause: The authentication service failed to retrieve the credentials of a user.
              Action: Enable tracing to determine the exact error.
          What step was in progress?

          Which OS? XP pro, Win7 Pro, Server 2003, or Server 2008? Not x64?


          Also see section 2.2 Permission Requirement for Installing Oracle Database XE. See the local users and groups applet via Start/Run/lusrmgr.msc and open up the Administrators group ...
          • 2. Re: XE Installation error
            It's during setup one of the last steps. I think XE it's creating DB.
            It's a virtual machine (VM ware) with "window server 2008" 32bit
            • 3. Re: XE Installation error
              For Windows, check the services applet and see if the oracle services got created. There should be four or five Oracle services- only two, the OracleSerivceXE and OracleXETNSListener are relevant for an XE install.

              The Start/Run/services.msc shortcut still works for server 2008.

              And verify that in the Start/Run window dialog box shows "This task will be created with administrative privileges". If you're not seeing that, refer back to the XE install guide for Windows.

              For a failed install, follow the deinstall steps to remove all installer bits, double check your membership in the local administrators group (Start/Run/lusrmgr.msc) left pane click Groups, right pane right click Administrators, select Properties.

              And run the install program with a right click/Run as Administrator, with the later versions of Windows the admin group membership does not mean a Run as Admin... role is active, unless specifically ... specified.