1 Reply Latest reply: Apr 24, 2013 2:24 PM by cj RSS

    OCIEnvNlsCreate() failed: OCI8+PHP+Linux+Oracle 11g

    1005004
      Hi All,
      I've been struggling with this since 3 days. I'm getting the following error while using oci_connect:
      Warning: oci_connect(): OCIEnvNlsCreate() failed. There is something wrong with your system - please check that LD_LIBRARY_PATH includes the directory with Oracle Instant Client libraries

      My system configuration:
      PHP : 5.3.3
      OS: Red Hat Enterprise Linux Server release 6.1
      Oracle: 11g
      OCI8: 1.4.9

      My phpInfo() shows that OCI8 is configured with PHP. I did set the LD_LIBRARY_PATH to Instantclient in httpd conf file itself and gave permission 777 just to make sure it's not permission issue. I did not set any ORACLE_HOME because my Oracle database is on a different server.

      Please help!!