0 Replies Latest reply: Apr 25, 2013 8:30 AM by 1005494 RSS

    Autodownload disabled, still shows warning...

    1005494
      I have to support several legacy applications built against previous versions of Java (1.4 and 1.6), these applications would prompt to install the version they were built against when they were first accessed from a new user profile... as none of our users are administrators this was causing some headaches which we have resolved with the following:

      c:\windows\sun\java\deployment\deployment.properties
      deployment.javaws.autodownload=never
      deployment.javaws.autodownload.locked
      deployment.insecure.jres=never
      deployment.insecure.jres.locked

      While this does prevent the user from only having the options to install the legacy Java version or not run the application, the users are still receiving a warning message which I'd like to know how to suppress:

      Warning - Old Version of Java Requested
      This application would like to use an old version of Java (1.6.0_18) that is not installed on your system. We recommend running this application with the latest version of Java on your computer.


      The buttons that are presented are "Run with the latest version" and "Cancel", cancel of course stops the application from running and thus the user from working. Run with the latest version allows the application to run, but the user is presented with this same dialog again every time they go to use the application. It's rather ridiculous, and this is with an application for which we've installed certificate and what not so it's trusted otherwise. Can this be suppressed? Can I get Java to a point where it just runs and if something isn't working correctly my tier 1/tier 2 staff can troubleshoot an actual issue instead of having to visit workstations just because?