This discussion is archived
10 Replies Latest reply: May 20, 2013 7:55 AM by 1005488 RSS

StorageTek L40

1005488 Newbie
Currently Being Moderated
I'm trying to install replacement tape drives into our StorageTek L40 robotic tape library. I've set the drive jumper settings (as per previously installed drives) and connected the SCSI and serial connectors properly. When I start the library, the LCD panel shows 'Unknown Drive' on the LCD panel for each drive slot. If I go into 'drive configuration' and try to select the SCSI ID manually it says it's invalid. I don't know what the problem is. I've tried different drive jumper settings, but could it be a problem with the SCSI ID ? Alternatively, could it be the library firmware, or the tape firmware ? I've heard some tape drives may need specific firmware to match the drive to a specific library. Does anyone have more up-to-date library firmware that I can try, as I can't find any downloads ? Here are the details:

Tape library: StorageTek L40
Tape library firmware: 2.14.01
Drive 1: SCSI_1, Quantum CL1101
Drive 2: SCSI_2, Quantum CL1101

I believe, but am not 100% certain, that these drive models were originally manufactured by Certance, before they were bought by Quantum around 2004.

Any help will be greatly appreciated.

Edited by: 1002485 on Apr 25, 2013 6:33 AM
  • 1. Re: StorageTek L40
    Nik Expert
    Currently Being Moderated
    Hi.
    Can you write any available information from original and replacement tape drive?

    Like P/N ; Model Number etc

    Regards
  • 2. Re: StorageTek L40
    1005488 Newbie
    Currently Being Moderated
    Thanks for replying Nik.

    I don't have the details of the old drives to hand, but they were both the same model of HP LTO Ultrium 2 drive. Here are the details of the replacement drives, which are both being detected by the server's SCSI controller and Windows, but not the library:

    Drive 1: Quantum CL1101 (formerly Certance ?), SN JD00GKG, PN TE4100-501, LTO Ultrium 3.
    Drive 2: Quantum CL1101 (formerly Certance ?), SN JD00HH8, PN TE4100-501, LTO Ultrium 3.

    Both drives are currently configured with jumper switches for SCSI IDs.
  • 3. Re: StorageTek L40
    Nik Expert
    Currently Being Moderated
    Hi.
    General it's not required any juper settings on tape drive at library.

    All changes do via Library operator panel.

    Can you say more details about library.
    You replace only one drive or both ?
    This drive for this library or general LTO drive ?

    Regards.
  • 4. Re: StorageTek L40
    Nik Expert
    Currently Being Moderated
    Hmm....
    It's look like handmade solutions :)
    Sun StorEdge[tm] L20 / L40 / L60 Tape Library was EOL at 11/2002
    LTO 3 was anonced at 2005 year.

    This library is OEM HP HP SureStore E Tape Library 20-Slot, 40-Slot, and 60-Slot Models
    ( some docs: http://h20000.www2.hp.com/bc/docs/support/SupportManual/lpg28458/lpg28458.pdf )

    But according proveded information you have standalone LTO3 Quantum drive.

    This library have modification : DLT/LTO ; HVD SCSI/ LVD SCSI, so without provided detailed information about
    configuration, P/N of components not clear what you have.

    Regards.
  • 5. Re: StorageTek L40
    1005488 Newbie
    Currently Being Moderated
    I've replaced both drives. Unfortunately I bought both drives about 5 years ago and they were both put into storage until now. I can't remember sourcing and evaluating them but am sure I checked their compatibility with the L40. The library is branded StorageTek and has no HP branding to my knowledge. The drives were always intended for use with our StorageTek libraries.

    Not sure if I understand your last post, Nik, but the HP SureStore E 4/40 looks like an entirely different library. We're using a StorageTek L40, not a SureStore.

    Edited by: huddie on Apr 25, 2013 10:12 PM
  • 6. Re: StorageTek L40
    Nik Expert
    Currently Being Moderated
    You a right.
    I confused with this library : "Sun StorEdge L20/L40/L60 "

    Sun not sell "StorageTek L40 Tape Library" and not present at HandBook.

    Some docs available here: http://docs.oracle.com/cd/E19196-01/index.html

    Regards.
  • 7. Re: StorageTek L40
    1005488 Newbie
    Currently Being Moderated
    Okay, so far I've still not been able to get our library to recognice the tape drives. It still says 'unknown drive'. I think I need either the StorageTek L40 firmware for the CL1101 drive model, or a different drive model with the StorageTek L40 firmware pre-installed.

    Obviously it would be best for us to obtain the firmware for the drives we have already purchased. This would be faster than having to source and purchase replacement drives again. Does anyone out there, inside or outside Oracle, have access to the necessary firmware, which they would be willing to provide to us? We would be willing to pay a small fee if necessary. This would be the drive firmware to allow Quantum CL1101 drives to work in a StorageTek L40 robotic tape library.

    ​Again, any help would be greatly appreciated.
  • 8. Re: StorageTek L40
    rukbat Guru Moderator
    Currently Being Moderated
    >
    ...snip...
    Does anyone out there, inside or outside Oracle, have access to the necessary firmware, which they would be willing to provide to us?
    Advice:
    You are asking someone to circumvent and violate the terms of their rights and privileges received when they purchased a support contract to give them access to those data files.

    I suggest you contact the company or companies directly and get whatever you need through legitimate channels.
  • 9. Re: StorageTek L40
    1005488 Newbie
    Currently Being Moderated
    Rukbat, I said and "inside or outside Oracle" and that we would be willing to pay if this is necessary. You said "You are asking someone to circumvent and violate the terms of their rights and privileges received when they purchased a support contract to give them access to those data files." I am not asking anyone to do anything of the sort. I welcome an offer from an Oracle member of staff to provide the firmware to us legally and at a cost if they are allowed to do so and wish to help. I'm not asking anyone to break rules. All above board. Please read forum posts before replying. Not doing so poisons the forum and makes working on a difficult issue harder.

    Re "I suggest you contact the company or companies directly and get whatever you need through legitimate channels.", we have no current maintenance contract on the library. If you're willing to help, can you point us to any 'legitimate channels' available to us for one-off support ? We're exploring legitimate options for us but there aren't many. Note we're in N. Ireland.

    Edited by: huddie on Apr 28, 2013 6:06 PM

    Edited by: huddie on Apr 28, 2013 6:14 PM
  • 10. Re: StorageTek L40
    1005488 Newbie
    Currently Being Moderated
    Installed the latest firmware on the library (v2.15.03). It detects the drives but when the drives eject, the robotic arm tries and fails to pull the tape the rest of the way out to unload it. Unable to figure out why.

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points