2 Replies Latest reply: Apr 29, 2013 7:28 AM by ssaammoo RSS

    Failed to Start Xampp Apache on Solaris 10

    ssaammoo
      Hello

      Hope someone can help me on my issue. I tried to install Xampp. all are working fine except Apache. I edited xampp starting script file by modifying port from 80 to 2110. the same for /opt/xampp/etc/httpd.conf I change listing port from 80 to 2110

      root@mtcksafhtest01 # ./xampp startapache
      XAMPP: Starting Apache...
      XAMPP: Error 1! Couldn't start Apache!
      root@mtcksafhtest01 # more logs/apachestart.log
      httpd: Syntax error on line 82 of /opt/xampp/etc/httpd.conf: Cannot load /opt/xampp/modules/mod_ldap.so into server: ld.so.1: httpd: fatal: libresolv.
      so.2: open failed: No such file or directory
      2oot@mtcksafhtest01 # ln -s /usr/lib/libresolv.so.2 /opt/xampp/lib/libresolv.so.
      root@mtcksafhtest01 # ldd /opt/xampp/modules/mod_ldap.so
      libldap-2.4.so.2 => /opt/xampp/lib/libldap-2.4.so.2
      liblber-2.4.so.2 => /opt/xampp/lib/liblber-2.4.so.2
      libc.so.1 => /lib/libc.so.1
      libgcc_s.so.1 => /opt/xampp/lib/libgcc_s.so.1
      libresolv.so.2 => /opt/xampp/lib/libresolv.so.2
      libresolv.so.2 (SUNW_2.2.2) => (version not found)
      libgen.so.1 => /lib/libgen.so.1
      libnsl.so.1 => /lib/libnsl.so.1
      libsocket.so.1 => /lib/libsocket.so.1
      libsasl.so.1 => /usr/lib/libsasl.so.1
      libssl.so.1.0.0 => /opt/xampp/lib/libssl.so.1.0.0
      libcrypto.so.1.0.0 => /opt/xampp/lib/libcrypto.so.1.0.0
      libmp.so.2 => /lib/libmp.so.2
      libmd.so.1 => /lib/libmd.so.1
      libscf.so.1 => /lib/libscf.so.1
      libdl.so.1 => /lib/libdl.so.1
      libdoor.so.1 => /lib/libdoor.so.1
      libuutil.so.1 => /lib/libuutil.so.1
      libm.so.2 => /lib/libm.so.2
      root@mtcksafhtest01 #
        • 1. Re: Failed to Start Xampp Apache on Solaris 10
          Pascal Kreyer-Oracle
          Update libresolv.so.2 library with the patch 142340-02
          • 2. Re: Failed to Start Xampp Apache on Solaris 10
            ssaammoo
            Thanks for reply.

            It didn't work for me:

            root@mtcksafhtest01 # patchadd /var/spool/patch/142340-02
            Validating patches...

            Loading patches installed on the system...

            Done!

            Loading patches requested to install.

            Version of package SUNWcsl from directory SUNWcsl in patch 142340-02 differs from the package installed on the system.
            Version of package SUNWcslr from directory SUNWcslr in patch 142340-02 differs from the package installed on the system.
            Done!

            The following requested patches do not update any packages installed on the system
            Packages from patch 142340-02 are not installed on the system.

            No patches to check dependency.
            root@mtcksafhtest01 # showrev -p | grep 142340
            root@mtcksafhtest01 # cat /etc/release
            Solaris 10 11/06 s10x_u3wos_10 X86
            Copyright 2006 Sun Microsystems, Inc. All Rights Reserved.
            Use is subject to license terms.
            Assembled 14 November 2006
            root@mtcksafhtest01 # showrev -p | grep 142341
            root@mtcksafhtest01 #