This discussion is archived
1 2 3 4 Previous Next 45 Replies Latest reply: May 8, 2013 8:31 AM by EdStevens Go to original post RSS
  • 45. Re: logon issue with OL 6.3
    EdStevens Guru
    Currently Being Moderated
    Dude wrote:
    debug3: Trying to reverse map address 192.168.56.1.
    This is actually normal since the VirtualBox host-only adapter acts on behalf of the client connection. Similarly, with the NAT adapter, the host adapter acts on behalf of the virtual machine.

    One thing to remember is that the host-only interface is no good for outgoing connections. Traffic should go out on your VirtualBox NAT interface.

    Looking at your previous output:
    and on the ill-behaved OL 6.3

    [root@vblnxsrv02 ~]# route -n
    Kernel IP routing table
    Destination Gateway Genmask Flags Metric Ref Use Iface
    0.0.0.0 192.168.56.1 0.0.0.0 UG 0 0 0 eth1
    I see that you have set 192.168.56.1 as the TCP/IP gateway. This is apparently not the case on your OL 5.6 machine.

    So I'm wondering, did you perhaps specify 192.168.56.1 as default gateway in the TCP/IP settings of your OL 6.3 virtual machine? You should not specify any gateway on that 192.168.56.102/103 interface. Just leave it blank. Compare it with the setting of your OL 5.6 machine.

    At least this would explain why your OL 6.3 machine cannot reach any DNS name server. It is not going to resolve 192.168.56.1 anyway, but at least it won't delay because it cannot connect to any DNS server.
    Houston, the Eagle has landed!

    As I built these two machines - vblnxsrv56 and vblnxsrv63 - I took screenshots of every step, to give me a complete record of choices I made and possibly map those to the final result. Going back through those, I see that the 5.6 setup never asked for a gateway. When the 6.3 did - simply as a property of configuring eth1 - I never gave it a thought and just entered the address of the VBox hostonly adapter. Probably a mental holdover from the way I configured under VMware.

    So I blew away the 6.3 machine and rebuilt it from scratch, this time simply leaving the gateway field blank when configuring eth1. Also left the DNS field blank, which I seem to recall at some point in the distant past -- possibly under VMware -- not being able to do that.

    And btw, 192.168.56.100 - 254 are usually reserved for host-only DHCP. You could try to enable the DHCP server on the host-only adapter in your TCP/IP settings on the VM and enable the DCHP server on the host-only adapter of VirtualBox preferences. You will also see it does not set a gateway.
    Yes. As mentioned earlier, on this (my office desktop) I have the host-only configured with the DHCP server DIS-abled. Yet my personal laptop, with the exact same version of VBox has it enabled and configured exactly as you say. I just installed that one a couple of weeks ago (new laptop) so I know it is at default settings. The evidence surely says I changed it on the office desktop, but I sure don't remember it.


    BTW, if you are curious as to why I'm configuring two NICs the way I am, take a look at [url https://forums.virtualbox.org/viewtopic.php?f=35&t=42385]this. I just this morning found that as I was starting to go through the VBox forum for some ideas. That's a bit encouraging because I had long ago come to that same configuration independently, but for the same reasons cited there. In retrospect, the only reason I have a NAT adapter at all is to allow me to download the packages needed for VBox guest additions and oracle-validated, while not requiring my own IP address. Once I'm past that point, the only communications these vm's should see is between each other and the host os. I guess I could set up my own local yum repository, but that would require its own care and feeding, and in regards to the VBox guest additions that solution would be a bit of a chicken-and-egg situation.

    In any event it looks like we can finally put this to bed. I certainly appreciate all the effort you've expended.
1 2 3 4 Previous Next

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points