5 Replies Latest reply: May 7, 2013 3:44 AM by mathieu.d RSS

    Unable to complete unload due to: null.

    0xFAFF
      SOA Suite 11.1.1.7

      I have a simple BPEL calling a stored procedure with a DB adapter. I did not configure the datasource on WebLogic correctly, and now I cannot delete it or fix it, or do anything else.

      When I try to deploy my composite application from JDeveloper I get:
      Error message from server:
      There was an error deploying the composite on AdminServer: [JCABinding] xxxr/1.0]Unable to complete unload due to: null.

      I can see in the Weblogic Console that the DB adapter is in "prepared" state, so it is not running.
      When I try to start it I get:
      weblogic.application.ModuleException: A <jndi-name> is specified for the resource adapter bean in weblogic-ra.xml, however no <resourceadapter-class> element is specified in ra.xml


      Configuration -> Outbound Connection Pool Configuration
      This is where I added "eis/DB/myAdapter" under groups and instances, I want to delete it now but it does not let me.

      Edited by: PerpetuallyPerplexed on May 6, 2013 7:27
      Ok I delted Dbadapter.rar, and re-installed it.

      Still having the same problems. Help would be appreciated.
        • 1. Re: Unable to complete unload due to: null.
          Arik
          Hi,

          If you don't have any other defined datasource you can delete the DbAdapter, and deploy it again.
          Probably you have a corruption with one of the files.

          Arik
          • 2. Re: Unable to complete unload due to: null.
            0xFAFF
            Thank you, I undeployed the database adapter, and redeployed it. This was helpful for resetting everything to default, but it did not solve the problem with deploying my composite. I still get "unable to complete unload due to null".

            If I remove the database adapter from my composite and BPEL, then I can deploy my project to weblogic. If I put the database adapter back into my composite & BPEL, then I get that same error back again.

            Does the JNDI need to be set correctly when creating the db adapter in jdev for it to deploy successfully?

            Which JNDI do I need to specify when creating the adapter? In WebLogic Admin Console:
            for javax.rsource.cci.ConnectionFactory
            under General tab
            I set
            JNDI Name: xyzConnPool- which is "The JNDI name of the Outbound Connection instance within this group."

            Is this what I specify in jdeveloper, or is it some other JNDI?
            • 3. Re: Unable to complete unload due to: null.
              mathieu.d
              Hi,

              When you want to use the DbAdapter there is some "preparation" to be made before using it in Jdev (in a SOA composite).
              Not sure how much you did already so I'll write the whole preparation you can make manualy.

              1 - First you need to create a weblogic data source.
              For that you can go in the weblogic admin console (not EM) to :
              - Services > Data source

              There you can create a Generic data source (for a JDBC connection). (be sure to remember the JNDI name of the data source).

              2 - You need to configure your DbAdapter for using the previous data source created
              Go to deployment, click on the DbAdater > Configuration > Outbound/outgoing connections
              Create a new outbound connection (set a new JNDI name not used already and different from the JNDI name of the data source). Once done, click on it and set the JNDI name of the data source in the xADataSourceName field of the table.

              Click on "save"

              3 - Redeploy the adapter with the new connection (button update)

              4 - In Jdev, open your _db.jca file. Set the adapter outbound connection JNDI name in the file (if it is not already the case)

              Note : The DbAdapter should be in "active/running" state (not prepared).

              Good luck,
              mathieu

              Edited by: mathieu.d on May 7, 2013 1:25 AM
              • 4. Re: Unable to complete unload due to: null.
                0xFAFF
                Thank you, that fixed it.

                Edited by: JasonSmithy on May 7, 2013 1:38 AM
                • 5. Re: Unable to complete unload due to: null.
                  mathieu.d
                  Ok,

                  Then can you check the server side logs ? Maybe there is more information in order to narrow down the issue.

                  Edit: Great.

                  Edited by: mathieu.d on May 7, 2013 1:44 AM