8 Replies Latest reply: Jun 12, 2013 1:20 PM by dba69 RSS

    Encryption/Decryption when usin RMAN to duplicate/clone

    dba69
      Given facts:
      rman is used to backup database A to disk
      rman is used to put those disk backups to tape
      rman is used to duplicate database A to database B on another host
      the duplicate process worked fine before we started testing encryption
      the duplicate process worked fine with database A having an encrypted column in one table in a non-encrypted tablespace

      Now, database A has an encrypted tablespace with nothing currently in it. The duplicate process now ultimately fails with ORA-19913, unable to decrypt backup.

      I am not using encrypted backups, not specifying encrypt or decrypt anywhere in the duplication process. The only thing that is encrypted is the one tablespace in database A. I have the same wallet files on Host A (database A) and Host B (database B). Wallets are open. So why does the duplication process fail because the backup cannot be decrypted?