0 Replies Latest reply: May 9, 2013 6:35 PM by 1008125 RSS

    Issues Installing / Upgrading Java 7 (Update 21)

    1008125
      Hey All -

      I've worked with automating deployments using SCCM for a few years now and love it. A week ago, I went through the usual steps to deploy the latest Java 7 Update 21. During testing, though, it didn't work.

      When installing Java 7 Update 21, the installation status gets to about 80%, then hangs. A window appears in the background which says "There was a problem starting C:\Program Files (x86)\Java\jre7\bin\installer.dll. The specified module could not be found"

      Since then, I have spent more time trying to get it to work than on anything else recently. I mean hours upon hours. I'm applying it to our company Gold Image (which currently has Java 7 Update 17 installed) and for testing have been using 4 Hyper-V VMs so that after a test, I can restore to checkpoint and test again in seconds. Below are some stats as well as
      a list of what I've tried so far...

      Stats
      - Installing to Gold Image which is Windows 7 x64
      - Windows is fully updated to this month
      - Java 7 Update 17 previously installed

      What I've Tried
      - Uninstalling Java 7u17 first
      - Rebooting after uninstall
      - Cleaning registry of Java-related keys (numerous different key combinations)
      - Java cleaning scripts (Example)
      - Registry / File snapshot comparisons
      - Copying Java 7 Update 21's installer.dll (with and without all other installed files) to destination before installation
      - Above step + registering it with regsvr32 (fails)
      - Redownloading installation package / files
      - Creating MST files / Not using MST files
      - Installing straight from EXE (Usually I extract the MSI from deployment)
      - Trying different MSIEXEC installation string switches
      - Adding logging switches to MSIEXEC string (logs didn't show anything helpful)
      Searched Google for hours
      - Countless combinations of the above

      Nothing ever appears in the Event Logs. Sometimes I can get it to install using some of the above methods without an error and it is even listed in Add/Remove Programs. When I go to Java's site to "verify the version", though, it errors out.

      I'm at my wit's end. Any suggestions?