This discussion is archived
1 Reply Latest reply: May 10, 2013 8:55 AM by Scott_Symonds RSS

REP-56048: Engine rwEng-0 crashed

960554 Newbie
Currently Being Moderated
Dear All,

Hi i am working on forms and report 11g on weblogic. My issue is i have a report(Orientation in Landscape)
which is calling from parameter form.We in migration process from 6i ro 11g. In 6i, it is working fine,but in 11g
We are getting the error

The report terminated with error:
REP-56048: Engine rwEng-0 crashed., job Id: 2094.

While calling the reports from parameter form.

Can anybody help me to solve this issue
  • 1. Re: REP-56048: Engine rwEng-0 crashed
    Scott_Symonds Explorer
    Currently Being Moderated
    For 11g Reports environments, it is strongly recommended to tune the Reports Server engines for your Reports environment. The Reports Server engines are responsible for generating your reports. The file rwserver.conf will need to be updated to tune the engines. If you are using the in-process reports server (rep_wls_reports_%COMPUTERNAME%_%ORACLE_INSTANCE%), the file is located in %DOMAIN_HOME%\config\fmwconfig\servers\WLS_REPORTS\applications\reports_11.1.2\configuration. If you are using the standalone reports server (RptSvr_%COMPUTERNAME%_%ORACLE_INSTANCE%), the file is located in %ORACLE_INSTANCE%\config\ReportsServerComponent\RptSvr_%COMPUTERNAME%_%ORACLE_INSTANCE%. Alternatively, you can also do this in Enterprise Manager FMW Control for the reports server you are working with (Basic Configuration and Advanced Configuration). Before updating this file in either rwserver.conf directly or in Enterprise Manager, please make a backup of rwserver.conf.

    For the recommended settings for your reports server engines, this knowledge base article is helpful to tune them: http://pitss.com/us/2012/10/09/recommended-reports-engine-settings/

    If you update the in-process reports server's rwserver.conf, please restart the WLS_REPORTS WebLogic server to activate the changes.
    If you update the standalone reports server's rwserver.conf, please restart the standalone reports server either in OPMN or in Enterprise Manager.

    If you continue to receive REP-56048 errors, there is a possbility that your reports could contain "unexpected characters" which could be causing the Reports server engines to crash when generating certain reports. Oracle Support note 285281.1 (Problem #11 part b) contains more information about this and how to solve the problem with this.

    As a general note, we recommend compiling your reports from rdf to rep before deploying them as you will experience an improvement in performance.

    Thanks,
    Scott

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points