This discussion is archived
2 Replies Latest reply: Jun 13, 2013 1:11 AM by XeM RSS

Manually created report not running on weblayout

XeM Newbie
Currently Being Moderated
Hi,

I have created a report manually on Report 10g the report is running on paper layout but when i try to run the same report using run button on report builder it displays blank page any idea what needs to be set with a manual report to run it on web. I have saved the report as JSP and rdf but both is producing no out put.
  • 1. Re: Manually created report not running on weblayout
    AlexDiniasi Journeyer
    Currently Being Moderated
    Hello,

    The web layout (that is, the web source) is primarily used for the .jsp format for added flexibility via the web for web developers using Oracle Reports.

    Only new reports created in Reports Builder 9i or higher using the Report Wizard and choosing "Create Web Layout only" or "Create both Web and Paper Layout"
    will contain some basic code in the "Web Source" which is the source for the web layout. In Reports 9i, reports created manually - without using the
    Report Wizard - will also have a blank web layout, unless you add your own code in the "Web Source". Furthermore, you will not have a web layout for any
    reports migrated from Reports 6i as web layouts were only introduced in Reports 9i. What the report did not have in a previous release or version is not
    going to be generated in the new release or version.

    You will need to add your own code to the "Web Source" in order for anything to be displayed in the web layout. Additionally, any changes made to the
    Paper Layout will not cross over to the Web Layout per confirmation with Development. You may use the rw:include tag in the Web Source (see Help)
    to obtain some of the paper layout in your web layout.

    Alternatively, you can still perform the following with Oracle Reports 9i or higher and use the .rdf to display the paper layout from the web as you have
    in the past with Oracle Reports 6i: http//webserver.domain:7779/reports/rwservlet?report=test.rdf&destype=cache&desformat=pdf&userid=scott/tiger@db

    Hope this helps.

    Kind regards,
    Alex

    If someone's answer is helpful or correct please mark it accordingly.
  • 2. Re: Manually created report not running on weblayout
    XeM Newbie
    Currently Being Moderated

    Thank you very much for your detail answer, i was busy with some other issues could't respond on time i am sorry for that.

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points