3 Replies Latest reply on May 24, 2013 5:31 PM by Colm Divilly-Oracle

    SQL Developer Error when connecting to Listener on Glassfish

    Steve_Macleod
      I am having some issues with connecting to Apex Listener via SQL Developer. I get "cannot connect to connection" when I attempt to connect.
      I do get apex pages (when I use the Glassfish default port - it doesn't seem to take the specified port which is defined as 7788 in the apex.properties at the config.dir location).
      I have defined the user via the war config (which is written to the credentials file), and added the users under default config > file realm in Glassfish.
      I wonder if anyone has had a similar issue?

      I am using the following:
      Glassfish 3.1.2.2
      Apex Listener 2.0.2.133.14.50
      SQL Dev 3.2.09

      Edited by: Steve_Macleod on May 24, 2013 2:42 PM

      Edited by: Steve_Macleod on May 24, 2013 2:57 PM
        • 1. Re: SQL Developer Error when connecting to Listener on Glassfish
          Colm Divilly-Oracle
          Steve_Macleod wrote:
          I am having some issues with connecting to Apex Listener via SQL Developer. I get "cannot connect to connection" when I attempt to connect.
          I do get apex pages (when I use the Glassfish default port - it doesn't seem to take the specified port which is defined as 7788 in the apex.properties at the config.dir location).
          The port specified in apex.properties is only used by Standalone Mode, the port that GlassFish uses is configured by GlassFish, not Listener.
          I have defined the user via the war config (which is written to the credentials file), and added the users under default config > file realm in Glassfish.
          You only need to do the former, doing the latter should have no effect, I would remove the user in the GlassFish file realm, to avoid causing confusion.
          I wonder if anyone has had a similar issue?
          Ensure you have spelt the role name correctly when setting up the user, any typos (it is case sensitive) and it won't match the role, and will therefore refuse access.

          You have disabled SSL verfication as well? (If you are not using SSL)
          http://docs.oracle.com/cd/E37099_01/doc/doc.20/e25066/install.htm#CHDJFAAI

          If neither of those work, try turning on logging in the Listener to see if the request is even reaching Listener (It sounds like it's not even connecting TBH).

          https://cdivilly.wordpress.com/2013/03/11/configuring-logging-with-oracle-application-express-listener-and-glassfish/
          I am using the following:
          Glassfish 3.1.2.2
          Apex Listener 2.0.2.133.14.50
          SQL Dev 3.2.09

          Edited by: Steve_Macleod on May 24, 2013 2:42 PM

          Edited by: Steve_Macleod on May 24, 2013 2:57 PM
          1 person found this helpful
          • 2. Re: SQL Developer Error when connecting to Listener on Glassfish
            Steve_Macleod
            Hi
            I have checked the username/groups are as follows:
            adminlistener Admin
            managelistner Manager

            The following entry has been added to the defaults.xml at config.dir location (I presume that this is used by Glassfish?)
            <entry key="security.verifySSL">false</entry>

            I've added the logger, but cant see any diagnostic messages.
            • 3. Re: SQL Developer Error when connecting to Listener on Glassfish
              Colm Divilly-Oracle
              Steve_Macleod wrote:
              Hi
              I have checked the username/groups are as follows:
              adminlistener Admin
              managelistner Manager
              This is incorrect, remove these users (I presume they are in the GF file realm), they are not used in 2.0.0. Follow the instructions here instead:

              http://docs.oracle.com/cd/E37099_01/doc/doc.20/e25066/install.htm#CHDEICAI
              java -jar apex.war user adminlistener "Listener Administrator"
              The following entry has been added to the defaults.xml at config.dir location (I presume that this is used by Glassfish?)
              <entry key="security.verifySSL">false</entry>

              I've added the logger, but cant see any diagnostic messages.
              The SQL Developer error message indicates it is not making a connection to the Listener so that more or less confirms this.