1 Reply Latest reply: May 28, 2013 2:34 AM by user9032609 RSS

    pkg set-publisher  fails with code 401

    user9032609
      I wanted to install a new zone but my Solaris 11 server complained it couldn't contact the Oracle server.
      I tried a lot of things. We have a valid supportcontract untill 08-2013 and i redownloaded the PEM-files and tried to install them.
      But i keep getting 401 errors.

      (i removed the all files from /var/pkg/ssl and redownloaded the pem-files and i unset the pkg publisher)

      pkg set-publisher -k /var/pkg/ssl/Oracle_Solaris_11_Support.key.pem -c /var/pkg/ssl/Oracle_Solaris_11_Support.certificate.pem -G '*' -g https://pkg.oracle.com/solaris/support/ solaris11
      pkg set-publisher: The origin URIs for 'solaris11' do not appear to point to a valid pkg repository.
      Please verify the repository's location and the client's network configuration.
      Additional details:

      Unable to contact valid package repository
      Encountered the following error(s):
      Unable to contact any configured publishers.
      This is likely a network configuration problem.
      https protocol error: code: 401 reason: Unauthorized
      URL: 'https://pkg.oracle.com/solaris/support'.

      What am i doing wrong?
        • 1. Re: pkg set-publisher  fails with code 401
          user9032609
          It seemed that there was a fault with our support contract.
          The reseller made some mistakes when entering our information and therefore the supportsystem didn't accept us.
          Although we could download the certificates we couldn't download any patches.

          After some emails and calls everything was put in to place and now our system is updating .

          Edited by: user9032609 on May 28, 2013 12:33 AM