2 Replies Latest reply: Jun 11, 2013 11:05 AM by d_seng RSS

    OWB Mapping stopped running

    samujjwalbasu
      HI All,

      Thanks for your help in advance.

      We have these OWB mappings and we have a automation framework built using PL/SQL.

      We call the OWB mappings using the "owbsys.wb_rt_api_exec.run_task()" function. These whole thing was running fine up untill Saturday 25th May 2013 (i.e. it run the Saturday's load properly).

      But it stopped working from Sunday, No error, no log just it is not able to call the mapping, it keeps on running, but if you see in the background this call is not calling that mapping.

      I tried to call that code, but no luck, it kept on running, not giving any error, but not doing any work as well.

      I have asked the DBAs if they have applied any change or done any maintenance activity on Saturday, but so far I havent got any conclusive answer.

      I run the "service_doctor.sql" script, all I found was that 3 procedure are invalid in OWBSYS schema due to DBMS_AWM other than that the "service_doctor.sql" return all fine, could the DBMS_AWM be the problem?

      I know this is a very open and vague question, but any tip and help will be highly appriciated, because I am completely lost now.

      Thanks for reading the whole problem.

      Regards,

      Samujjwal Basu
        • 1. Re: OWB Mapping stopped running
          samujjwalbasu
          Hi All,

          As an update:

          We have done a trace on the session, and what we found that internally it was hanging when it was trying to delete from a table called "WB_RT_NOTIFY_QUEUE_TAB".

          I should tell you that we are not trying to delete anything from that table in our code, but it is something the OWB code itself is doing.

          Any help is appreciated.

          Regards,

          Samujjwal Basu
          • 2. Re: OWB Mapping stopped running
            d_seng

            Check for any wait events for a lock.

             

            Try restarting the database, potentially releasing the lock.

             

            Try creating a process flow and execute that using sqlplus_exec_template.sql and see if that succeeds.

             

            Let us know if any of this works.

             

            Cheers,

            Dhruva