3 Replies Latest reply: May 29, 2013 12:45 PM by Vishal_EM_assist RSS

    OSB services didn;t got discovered in OEM 12cR2

    Roshni Shankar
      Hi All,

      I hace installed OEM 12cR2. I want to monitor OSB services (Proxy and Business) from OEM 12cR2. Following one of the Oracle document I opened the osb console and turned on the service monitoring for proxy service and set the level to "pipeline". Also I turned on the service monitoring for business service. I refreshed the OSB domain which has been added in OEM and in which my proxy and business service have been deployed.

      But I find no data captured for my proxy and business service. The page for OSB services shows no entry for my proxy and business service. Even the services didn't get discovered. The OSB services page in OEM shows a blank page even if I turned monitoring for osb services on in my osb console.

      Please suggest what I should..where I went wrong.

      Also I checked by turning on the service monitoring for proxy service and set the level to "action" but this also didn't work.

      Please help!!

      thanks in advance!!
        • 1. Re: OSB services didn;t got discovered in OEM 12cR2
          Vishal_EM_assist
          Do you see metrics in the Health of Services tab in OSB console?
          • 2. Re: OSB services didn;t got discovered in OEM 12cR2
            Roshni Shankar
            Hi,

            yes, I am able to see metrics in the Health of Services tab in OSB console but the values are not available in OEM 12cR2. Can you help me on this?
            • 3. Re: OSB services didn;t got discovered in OEM 12cR2
              Vishal_EM_assist
              I am little confused here. What I understood from your other posts is that you do not even see the proxy/business services in EMCC OSB target home page, but now it sounds like you do see the services, but you don't see the metrics. Is that correct? Lets take two possibilities:

              1) OSB business/proxy services are discovered in EMCC. but the metrics are not collected. For this, check the following:

              a) The agent monitoring your OSB domain shouldn't be down and there should be no incident due to this cause on the OSB homepage. If yes, file a SR to get agent issue resolved.

              b) If agent is up, then go to OSB taget menu > Monitoring > Metric and collection settings and make sure that the "OSB Business Service Metrics" and "OSB Proxy Service Metrics" are not disabled and the time interval is not too large such as in days/weeks. Make sure all other metrics that you are interested in are also not disabled.

              c) If both of the above are true, then also make sure that constant traffic is flowing through OSB so that EMCC gets enough cycles to collect the data from the hosts.

              2) OSB business/proxy services are NOT discovered in EMCC at all. For this, do the following:

              a) Refresh the OSB domain once and see if these services get discovered.

              b) If refresh is also not discovering these services, then this seems to be some OSB/Mbeans level misconfiguration and will need to be worked by support as it would be a client specific issue, so create a SR.

              Also, can you close the other threads around OSB monitoring topic so that we can work on just this thread since there seems to be few threads with duplicate information floating around.