2 Replies Latest reply: Jun 13, 2013 4:14 AM by Ed Rudans RSS

    Error when running root.sh after 11.g2 standalone rac installation

    user3183694
      OS: redhat 5.8
      After completing the installation, when running root.sh , I get error:


      [root@vmorarac1 oracle]# ./root.sh

      Running Oracle 11g root.sh script...



      The following environment variables are set as:

      ORACLE_OWNER= oracle

      ORACLE_HOME= /u01/app/11.2/oracle



      Enter the full pathname of the local bin directory: [usr/local/bin]:

      The file "dbhome" already exists in /usr/local/bin. Overwrite it? (y/n)

      [n]: y

      Copying dbhome to /usr/local/bin ...

      The file "oraenv" already exists in /usr/local/bin. Overwrite it? (y/n)

      [n]: y

      Copying oraenv to /usr/local/bin ...

      The file "coraenv" already exists in /usr/local/bin. Overwrite it? (y/n)

      [n]: y

      Copying coraenv to /usr/local/bin ...



      Entries will be added to the /etc/oratab file as needed by

      Database Configuration Assistant when a database is created

      Finished running generic part of root.sh script.

      Now product-specific root actions will be performed.

      Unrecognized character \x03 in column 3 at /u01/app/11.2/oracle/perl/lib/5.10.0/File/Basename.pm line 1.

      Compilation failed in require at /u01/app/11.2/oracle/crs/install/roothas.pl line 115.

      BEGIN failed--compilation aborted at /u01/app/11.2/oracle/crs/install/roothas.pl line 115.
        • 1. Re: Error when running root.sh after 11.g2 standalone rac installation
          FreddieEssex
          In my experience most errors can be resolved by 1) Google and 2) Metalink.

          If you google an error and get no hits and you also get nothing on Metalink, then in all likelihood this means one of two things.

          1) You did something very wrong and unexpected, like you didn't follow the pre-reqs or the instructions.
          2) You've hit a bug.

          For point 1 you might want to review what you've done and ensure you haven't deviated from the install document

          For point 2 you'll have to raise an SR with MOS.

          Have you tried removing/cleaning everything you've installed and re-running the install?
          • 2. Re: Error when running root.sh after 11.g2 standalone rac installation
            Ed Rudans

            Based on error messages you are getting it narrows down to perl issue and invalid character present in perl script.

            Have you or someone modified the perl script? Usually it is required to modify the scripts to point toproper perl location. Sometimes when you modify the script, the text editors could insert some characters in wrong encoding, etc. So I suggest to do comparison to perl scripts from the nodes with the same psu levels where installation was sucessfull., just compare filesize and if its different, then you could possible copy right scripts over current ones.

             

            The GI installations are very hard to investigate remotely, there could be too many things that can be wrong, so oracle support is your friend.

            As general thing I always recommend to install latest PSU before root.sh script execution.

             

            Ed Rudans

            erudans.blogspot.com