1 Reply Latest reply: Jun 12, 2013 11:17 AM by Ed Rudans RSS

    GI installation - OUI hung on Prerequisite check screen

    1013093
      Hi,

      During installation/upgrade ( from 11g R1 to R2 - 2 node RAC system- Linux64) OUI screen hung on prerequiste check screen. After applying fix as per Oracle note, (EMCPOWER storage bug) it started progressing but again hung on OCR check.

      If i ran the /runcluvfy.sh this also hung after two steps.

      Performing pre-checks for cluster services setup

      Checking node reachability...

      Check: Node reachability from node "jawbone"
      Destination Node Reachable?
      ------------------------------------ ------------------------
      glockenspiel yes
      jawbone yes
      Result: Node reachability check passed from node "jawbone"


      Checking user equivalence...

      Check: User equivalence for user "crs"
      Node Name Status
      ------------------------------------ ------------------------
      jawbone passed
      glockenspiel passed
      Result: User equivalence check passed for user "crs"

      Next step as per the above script is

      Checking node connectivity..._

      Checking hosts config file...

      When i ran the following command, its working fine. We are getting output.

      ./runcluvfy.sh stage -pre crsinst -n glockenspiel,jawbone -verbose

      What is the difference between the above two commands why with upgrade option it hung?

      thanks in advance.

      thanks
      Kannan
        • 1. Re: GI installation - OUI hung on Prerequisite check screen
          Ed Rudans

          Hi Kannan,

           

          The upgrade option will trigger additional checks related to upgrade, for instance ASM upgrade related checks, so its clear that cluvfy hangs on these additional checks.

           

          I remember we hit similar issue and it was related cluvfy was unable to check ASM version and related information.

           

          Also, try the magic trick - go to your .profile and comment out the bash string, if exists.  Rerun cluvfy.

           

          First thing to do in your case is to identify where exactly cluvfy stuck. You can enable tracing by setting the environment variable SRVM_TRACE to true, trace files are created in the CV_HOME/cv/log directory. This will provide you with more information and you can raise a SR with oracle if needed.

           

          In case you sure that all reqs are fine, you still can launch the installation ignoring the checks with -ignorePrereq option.

           

          Regards

           

          Ed Rudans

          erudans.blogspot.com