0 Replies Latest reply: Jun 15, 2013 12:32 AM by 901647 RSS

    Delete Web Apps using WLST not completely working - Quick question

    901647

      Hi All

       

      We have a simple wlst script where we want to delete all the running web applications and delete the servers serving them

      We have

       

      config()

      cd('Applications')

      delete('App1')

      delete('App2')

       

       

      drw- App1

       

      MBean type Application with name App1 has been deleted successfully.

      No stack trace available.

      Problem invoking WLST - Traceback (innermost last): File "removeApp.py", line 46, in ?

      File "<iostream>", line 549, in delete File "<iostream>", line 1847, in raise

      WLSTException WLSTException: Error occured while performing delete : Could not find the instance for Server1

       

      But App2 is not deleted successfully.

      We went to Admin console and found that under tab

      Summary of Deployments

       

      App2 is listed as Installed State.

      When we drill inside it, meaning clicking App2 link, those information on

      Path:/ webapps/ App2/ app

       

      Deployment Plan:/ webapps/ App2/ plan/ plan. xml

       

      are no longer there since we deleted the servers earlier.

       

      How to do use WLST commands to complete remove those webapps entries in deployment section tab ?

      We don't want them to show up on Admin console anymore after deletes.

       

      Thanks