0 Replies Latest reply on Jun 20, 2013 4:19 PM by 980013

    gpj error - wrong initialize update response length

    980013

      Hello,

       

      I got a new smart card to work with, a Sm@rtcafe expert 6.0 and I can't use it with gpj. I tried it easy and just used the list command and got the following output:

       

      >java -jar gpj.jar -list

      Found terminals: [PC/SC terminal OMNIKEY CardMan 3821 0]

      Found card in terminal: OMNIKEY CardMan 3821 0

      ATR: 3B FE 18 00 00 80 31 FE 45 53 43 45 36 30 2D 43 44 31 34 35 2D 6E 46 A0

      DEBUG: Command  APDU: 00 A4 04 00 07 A0 00 00 01 51 00 00

      DEBUG: Response APDU: 6A 82

      Failed to select Security Domain GP211 A0 00 00 01 51 00 00 , SW: 6A 82

      DEBUG: Command  APDU: 00 A4 04 00 08 A0 00 00 00 18 43 4D 00

      DEBUG: Response APDU: 6A 82

      Failed to select Security Domain GemaltoXpressPro A0 00 00 00 18 43 4D 00 , SW: 6A 82

      DEBUG: Command  APDU: 00 A4 04 00 08 A0 00 00 00 03 00 00 00

      DEBUG: Response APDU: 6F 10 84 08 A0 00 00 00 03 00 00 00 A5 04 9F 65 01 FF 90 00

      Successfully selected Security Domain OP201a A0 00 00 00 03 00 00 00

      DEBUG: Command  APDU: 80 50 00 00 08 CB BE 6D 77 06 5F 69 F2

      DEBUG: Response APDU: 00 00 11 73 95 00 08 22 08 64 01 03 00 8B 32 D6 AD 37 C1 1

      4 F3 85 93 C0 3B 99 DF 96 72 90 00

      javax.smartcardio.CardException: Wrong initialize update response length.

               at net.sourceforge.gpj.cardservices.GlobalPlatformService.openSecureChannel(Unknown Source)

              at net.sourceforge.gpj.cardservices.GlobalPlatformService.main(Unknown Source)

       

       

      When I try this with my JCOP 4.2 everything works fine and I get a list with all installed applets. The same error I get when I try to install a *.cap file. With the JCOP 4.2 it works fine

       

      Can someone of you may tell why it doesn't work with the sm@rtcafe expert 6.0 or why this error is thrown? Maybe its important to mention that both cards run Global Plattform 2.1.1. The Jcop runs java 2.2.2 and the sm@rtcafe runs Java 3.1 classic.

       

       

      Thank you in advance