3 Replies Latest reply on Jun 21, 2013 3:23 PM by user10763276

    Inbound TA1- Couldn't find Agreement!


      Hi All,

      I am having issue in consuming inbound TA1 file with no Agreement found error. Though I have created TA1 def with Document Versrion 5010X220A1, but still why does is it looking for 5010 from the below error, I am finding no clue.

      I know for Inbound to work without issue we need to make sure the 4 parameters From Party, To Party, document type and document protocol version but how do I do that for a TA1???

      I have given the TA1 file name with Document Type and Protocol Version as (XXX_XXX_TA1_5010X220A1.dat).

      Agreement not found for trading partners: FromTP XXX, ToTP XXXX (Modified TP names)with document type TA1-5010-INBOUND.

      Please advise...

        • 1. Re: Inbound TA1- Couldn't find Agreement!

          I faced a similar problem recently with xml document type. I always got the agreement not found error  with document type xxxx--null-INBOUIND. The issue was resolved after I exported the entire MDS repository, purged all the mds data and instance data and imported the repository back. It started working fine.


          ~Ismail M.

          • 2. Re: Inbound TA1- Couldn't find Agreement!

            Thanks for your reply Ismail. I have done the steps suggested and I see no difference. I still see the same error. We are not specifying the document version in the TA1 file and the only place we are specifying the version is in the TA1 file name. So it is clear that the version is not picked from the File Name, so how do we give the version and document names for the inbound TA1 to pick the right Agreement??? Thanks---

            • 3. Re: Inbound TA1- Couldn't find Agreement!

              Finally!! I am able to resolve the problem!!! So, as per my understanding TA1's generated and consumed are based on 5010 version only. So created new definition for TA1 under 5010 version and new set of Agreements, which solved my problem.