4 Replies Latest reply: Jun 30, 2013 9:43 AM by Andre_NL RSS

    Subject Areas window problem

    Andre_NL

      Hello, I am new to OBIEE.

      I added the metadata of my source database to the repository.

      Then in Oracle BI, I choose 'New analysis', I see on the left my metadata (in the Subject Areas window), so that starts good. But when I want to expand a table, to see the colums, a circle appears, and nothing happens. The circle is not moving/circling. What could be going wrong ?

      Note. The BI Administration tool is not started/open.

       

      Thanks in advance, best regards, André.

        • 1. Re: Subject Areas window problem
          Srini VEERAVALLI

          Make sure the subject area is consistent.

           

           

          ~ http://cool-bi.com

          • 2. Re: Subject Areas window problem
            Andre_NL

            The Consistency Check gives two types of errors:
            1. Logical Table. The logical table fct_customer_base os not joined to any other logical table.
            2. Physical foreign key. Physical table agg_customer_base and dim_date have multiple joins.

            For me, these are not real errors:
            1. It's logical that a fact is not referenced to.
            2. It's by design that the aggregate table has serveral date fields which give serveral joins to the same dimension table.

            I hope these findings of the Consistency Check are not real problems for OBIEE. Or is this the reason why the Subject Area window is not working ?

            Thanks in advance, best regards,
            André.

            • 3. Re: Subject Areas window problem
              KBabu

              Hi Andre

              If those 2 are generating as warnings, you can leave it temporarily..if those 2 are errors, it needs to be fixed and then the SUBJECT AREA will show you the table names.if still not showing, then again RPD needs to be checked

              Best Practices..the Repository should be consistent without any warnings (or) errors

              Can i get the nQSErrors of those two...1st one it seems you didnt gave joins to that table correctly

              • 4. Re: Subject Areas window problem
                Andre_NL

                I solved a few issues and now I don't have any errors or warnings anymore in the 'Presentation' layer. In the 'Business Model and Mapping' layer there are also no errors or warnings. Only in the 'Physical' layer I get errors:

                [38015] Physical tables "ORACLE11".."DM_CUSTOMER_BASE_AGG" and "ORACLE11".."DATAM"."DM_ADDRESSES_DIM" have multiple joins. Delete new foreign key object if it is a duplicate of existing foreign key.

                 

                Is this issue in the physical layer a problem ? I would find it ridiculous that multiple relations to one dimension are not allowed, because they are not duplicates but have different meaning.

                 

                Thanks in advance,

                André.