2 Replies Latest reply: Jul 2, 2013 11:21 AM by AbdurRahman RSS

    admin password cannot be reset

    AbdurRahman

      Good day all,


      i was trying to login to apex development environment but i could not login.

       

      i have run the apxchpwd.sql script to change the admin password several times but i still got the same error message "Invalid Login Credentials".

      i have even run the update statement below but i still got the same error message.

      update wwv_flow_fnd_user

      set change_password_on_first_use ='N'

      where lower(user_name) = 'admin'

       

      i am working on oracle 11.2.0.1.0 and the apex is  APEX_4.2.1 on ORACLE HTTP SERVER WITH MOD_PLSQL

       

      If there is any other way to unlock the admin password kindly assist.

       

      thanks

      AbdurRahman

        • 1. Re: admin password cannot be reset
          Jeff E

          This problem has been encountered before when running the incorrect apxchpwd.sql script.  Verify the apxchpwd.sql script you are running is for changing the apex version you are on.  If you have upgraded your APEX version you cannot used the apxchpwd.sql provided with the original database install.  You need to use the apxchpwd.sql contained within the upgraded version's zip file.

           

          This query may help you determine which APEX version you are on:

           

          SELECT comp_id, comp_name, version, status, schema

             FROM dba_registry

          WHERE comp_id = 'APEX'

           

          View the contents of the apxchpwd.sql script and read the modification comments.  The modification comments will give you an idea of which schema the script will run against.  Make sure it is the same as the schema of the APEX version you are running.

           

          Also this script is only for changing the admin password for the INTERNAL workspace.  If you need to change the admin password for another workspace you will need to do it from the INTERNAL workspace.

          • 2. Re: admin password cannot be reset
            AbdurRahman

            hello jeffE,

             

            Thanks so mush for the response, i did follow your instruction and i found out that the version is correct with the script, also it is running against the correct schema. the version is

            4.2.1.00.08 according to the query you told me to run.

             

            What really happened is that i was using it before.i forgot the admin password and my own password. so i want to change all the password to the one i will be able to remember. so i did uninstall apex drop the schemas anonymous,apex_040200,apex_public_user and flows_files.

            i did a reinstallation of apex,i could not login again just like the first instance.

             

            I really dont know what i have done wrong.

             

            Thanks once again