3 Replies Latest reply: Jul 18, 2013 12:23 PM by jivanvl RSS

    Reset form elements


      Hi, I've been having this weird issue as of late, it goes something like this.


      I use a report to select a record so I can edit it on a form, from there I click Apply Changes. I pick another one and the past record is still there. Any ideas how can I solve this?


      Thanks in advance


      Using Oracle Apex 4.2.2 with Oracle Apex Listener and Oracle Database XE 11g

        • 1. Re: Reset form elements

          Hi 1009130, please access your profile and update your handle to something more personal.


          It appears that something on your form is doing what you think it should.  Have you tried just rebuilding the report and form from the create page wizard for a Form on a Table with Report?


          If that is not an option, typically on the Form page there is a process that clears the page cache after the DML process is successful.  Take a look for a process like that, see where it is firing if at all.



          • 2. Re: Reset form elements

            Unfortunately I can't recreate the form, But let me explain further.


            This page has two regions, the form region and the report region, and when you select a record from the report region, the form region allows for editing. I tried with the aforementioned process but to no avail.


            Thanks for lending me a hand

            • 3. Re: Reset form elements

              I solved this a coule of days ago, it was a silly mistake of mine.


              You have to use branching in order for the dml process to run, also make sure that the button you use SUBMITS the page, then on the branching process add the condition so the branch only affects such button