11 Replies Latest reply: Jul 4, 2013 10:36 AM by Hussein Sawwan-Oracle RSS

    Error in form builder 10g

    996605

      HI,

      I have installed oracle EBS 12.1.1 and installed developers suite 10g

      while running the form builder.

      It results me

      frm-92160 webclient is too old.


       

      Please help.

       

      Thanks and Regards,

      Srikanth

        • 1. Re: Error in form builder 10g
          Hussein Sawwan-Oracle

          What is your OS?

           

          Is the issue when you bring forms builder up?

           

          Forms 10gR2 (10.1.2.x ) Developer Suite not Running after Install of Forms 11.1.x (11g) on Windows [ID 1354732.1]

          How To Bring Up 10G Forms Builder In R12 Environment? [ID 579318.1]

          Using the OracleAS 10.1.2 Forms and Reports Builders with Oracle Applications Release 12 [ID 444248.1]

           

          Thanks,

          Hussein

          • 2. Re: Error in form builder 10g
            996605

            Hi Hussein.

             

            my OS is 2003 server

             

             

            Thanks and regards

            Srikanth

            • 3. Re: Error in form builder 10g
              Hussein Sawwan-Oracle

              996605 wrote:

               

              Hi Hussein.

               

              my OS is 2003 server

               

               

              Thanks and regards

              Srikanth

               

              Is it 32-bit or 64-bit?

               

              Do you have 12.1.x installed on the same server where you are trying to run Forms Builder from?

               

              Have you installed Developer 10g in a separate ORACLE_HOME?

               

              How do you get the error?

               

              Thanks,

              Hussein

              • 4. Re: Error in form builder 10g
                996605

                Hi

                 

                32 Bit OS.

                EBS R12.1.1

                I have installed in same server.

                I have installed on same ORACLE_HOME.

                While running the Form from the from builder.

                Jinitiator started and got error in the FORM.

                 

                 

                Regards,

                Srikanth

                • 5. Re: Error in form builder 10g
                  Hussein Sawwan-Oracle
                  I have installed on same ORACLE_HOME


                  You shouldn't install Developer 10g in the same ORACLE_HOME as this would impact your 12.1.1 instance -- No wonder you are getting FROM-92160 error.


                  Developer 10g should be installed on a separate ORACLE_HOME.


                  Thanks,

                  Hussein

                  • 6. Re: Error in form builder 10g
                    996605

                    How to install on different ORACLE_HOME

                     

                    Is there any solution for this issue.?

                    • 7. Re: Error in form builder 10g
                      Hussein Sawwan-Oracle

                      When you run Developer 10g installer, it will prompt you to type the directory and this should be a new one (not one of 12.1.1 directories) -- How to install oracle developer suite 10g on windows xp and windows 7 - YouTube

                       

                      Is your 12.1.1 instance working properly? If yes, then you can proceed with the installation of Forms/Reports 10g as mentioned above.

                       

                      Thanks,

                      Hussein

                      • 8. Re: Error in form builder 10g
                        996605

                        Yes Apps instance is running correctly.

                        Actually i have installed with other ORACLE_HOME name and in a separate directory.

                        After installing Developers suite 10G i ran autoconfig on apps tier.

                        And in a separate directory.

                        After running autoconfig. Cannot use developer suite.

                         

                         

                        Regards,

                        Srikanth

                        • 9. Re: Error in form builder 10g
                          Hussein Sawwan-Oracle
                          After running autoconfig. Cannot use developer suite


                          Did AutoConfig complete successfully?


                          Please mention the steps you are following to reproduce the issue.


                          Thanks,

                          Hussein

                          • 10. Re: Error in form builder 10g
                            996605

                            Yes Autoconfig completed successfully.

                            I have installed the R12.1.1.

                            later installed dev suite and concurrent manager gave a error.

                            i have run autoconfig and issue with conc manager fixed.

                            I tried to create and run a sample Form.

                            when running from it asked for Jinitiator.

                            and placed JVM of java 1.6 in the jinitiator folder.

                            while running it gave me frm-92160 webclient is too old.

                             

                            while starting OC4J it gave following text

                             

                             

                            C:\Windows\system32>c:\DevSuiteHome_1\jdk\bin\java  -Doracle.security.jazn.config=c:\DevSuiteHome_1\j2ee\DevSuite\config\jazn.xml -Doracle.home=c:\DevSuiteHome_1 -DORACLE_HOME=c:\DevSuiteHome_1 -jar c:\DevSuiteHome_1\j2ee\home\oc4j.jar -userThreads -config c:\DevSuiteHome_1\j2ee\DevSuite\config\server.xml

                            13/07/04 14:12:29 Auto-unpacking C:\DevSuiteHome_1\forms\j2ee\formsapp.ear... done.

                            13/07/04 14:12:29 Auto-unpacking C:\DevSuiteHome_1\forms\j2ee\formsapp\formsweb.war... done.

                            13/07/04 14:12:29 Auto-deploying forms (New server version detected)...

                            13/07/04 14:12:29 Auto-deploying file:/C:/DevSuiteHome_1/j2ee/home/default-web-app/ (New server version detected)...

                            13/07/04 14:12:29 Auto-deploying file:/C:/DevSuiteHome_1/j2ee/home/applications/dms0/ (New server version detected)...

                            13/07/04 14:12:29 Auto-deploying file:/C:/DevSuiteHome_1/j2ee/home/applications/dms/ (New server version detected)...

                            13/07/04 14:12:29 Auto-deploying Forms Services (New server version detected)...

                             

                            13/07/04 14:12:29 Copying default deployment descriptor from archive at C:\DevSuiteHome_1\reports\j2ee\reports_ids\web/WEB-INF/orion-web.xml to deployment directory C:\DevSuiteHome_1\j2ee\DevSuite\application-deployments\reports\web...

                            13/07/04 14:12:29 Auto-deploying file:/C:/DevSuiteHome_1/reports/j2ee/reports_ids/web/ (New server version detected)...

                            13/07/04 14:12:29 Auto-deploying file:/C:/DevSuiteHome_1/reports/j2ee/reports_ids/demo/ (New server version detected)...

                            13/07/04 14:12:30 Oracle Application Server Containers for J2EE 10g (10.1.2.0.2) initialized

                             

                             

                            i tried to re install dev suite.

                            when dev suite installed can run the forms but conc manager is not starting .

                            after running autoconfig. the issue is coming.

                             

                            regards,

                            Srikanth

                            • 11. Re: Error in form builder 10g
                              Hussein Sawwan-Oracle
                              I tried to create and run a sample Form.

                               

                              Are you trying to run the form from Forms Builder? If yes, then don't expect it to run and you will only need to make sure it compiles successfully then copy it to the right $PRODUCT_TOP/forms/<LANG> directory and run it from the application (after registering it).

                               

                              Thanks,

                              Hussein