This discussion is archived
3 Replies Latest reply: Aug 1, 2013 12:29 PM by JohnGoodwin RSS

Please comment on configtool.sh hung at 20% when deploying RA Web app

Mike Paladino Newbie
Currently Being Moderated

I have a distributed installation of EPM version 11.1.2.1.  The application tier is a 3 node weblogic cluster.  We applied a couple patches to all tiers and in the posteps we had to redeploy the RA application.  This worked fine on the first node but on the other 2 subsequent nodes configtool.sh would hang after completing the Pre-steps on the HSS registry and before the Pre-steps on RA at 20%

We have tried everything I can think of to get around this

error is

Exception in thread "Thread-14" java.lang.NullPointerException

at com.hyperion.config.document.StorageMisc.mergeVTConfigFiles(StorageMisc.java:279)

at com.hyperion.config.wizard.impl.RunAllTasks.execute(RunAllTasks.java:441)

at com.hyperion.config.wizard.impl.RunnAllTasksState.run(RunnAllTasksState.java:90)

at java.lang.Thread.run(Thread.java:619)

 

This is happening on 2 different nodes in the cluster


I have rolled back the patch on those nodes and tried to redeploy - that did not work

I have opened an SR with Oracle and uploaded detail trace data which contained nothing substantial

I have even tried the registry cleanup utility from 11.1.2.2 (at the request of support) and that did not fix the issue


any help would be great

 

The last entries in the configtool.log are /swpkg/oracle/hyperion/Oracle/Middleware/user_projects/epmsystem4/tmp/jazn-data4188527176104099455xml,modified [Fri Mar 22 17:51:25 EDT 2013]] [2013-06-21T14:20:19.009-04:00] [EPMCFG] [TRACE] [EPMCFG-02188] [oracle.EPMCFG] [tid: 20] [ecid: 0000JxbxiUKBl3IpIoG7yf1Hl9^N000005,0] [SRC_CLASS: com.hyperion.hit.fusion.FusionComponent]  [3,863 more files exist in EPM_ORACLE_INSTANCE. Skipping logging] [2013-06-21T14:20:19.010-04:00] [EPMCFG] [TRACE] [EPMCFG-02160] [oracle.EPMCFG] [tid: 20] [ecid: 0000JxbxiUKBl3IpIoG7yf1Hl9^N000005,0] [SRC_CLASS: com.hyperion.hit.fusion.FusionComponent] End of file listing [2013-06-21T14:20:19.014-04:00] [EPMCFG] [NOTIFICATION] [EPMCFG-01001] [oracle.EPMCFG] [tid: 20] [ecid: 0000JxbxiUKBl3IpIoG7yf1Hl9^N000005,0] [SRC_CLASS: com.hyperion.config.wizard.impl.RunAllTasks] trace: Validation folder found for product raframework

 

Message was edited by: MikePaladino After exiting configtool we see these errors also [2013-07-03T16:30:54.847-04:00] [EPMCFG] [WARNING] [EPMCFG-01011] [oracle.EPMCFG] [tid: 12] [ecid: 0000JyaEk8cBl3IpIoG7yf1Hp8_U000006,0] [SRC_CLASS: com.hyperion.cis.ConfigToolDocument] Failed to parse Hub Registration task priority: priority = null [2013-07-03T16:30:55.097-04:00] [EPMCFG] [WARNING] [EPMCFG-01011] [oracle.EPMCFG] [tid: 12] [ecid: 0000JyaEk8cBl3IpIoG7yf1Hp8_U000006,0] [SRC_CLASS: com.hyperion.cis.ConfigToolDocument] Failed to parse Hub Registration task priority: priority = null [2013-07-03T16:30:55.154-04:00] [EPMCFG] [WARNING] [EPMCFG-01011] [oracle.EPMCFG] [tid: 12] [ecid: 0000JyaEk8cBl3IpIoG7yf1Hp8_U000006,0] [SRC_CLASS: com.hyperion.cis.ConfigToolDocument] Failed to parse Hub Registration task priority: priority = null [2013-07-03T16:30:55.337-04:00] [EPMCFG] [TRACE] [EPMCFG-01001] [oracle.EPMCFG] [tid: 12] [ecid: 0000JyaEk8cBl3IpIoG7yf1Hp8_U000006,0] [SRC_CLASS: com.hyperion.config.wizard.impl.RunnAllTasksState] trace: Configuration interrupted...

  • 1. Re: Please comment on configtool.sh hung at 20% when deploying RA Web app
    Mike Paladino Newbie
    Currently Being Moderated

    We have figured it out.  Somehow the following folder was empty

    $EPM_ORACLE_HOME/products/biplus/validation/

     

    We copied the following files from the install that was working(below) from another node in the WebLogic cluster that was working and the deploy finished

    copied these files from the good server and it seems to have worked

    ls -ltr

    total 504

    drwxr-x--- 2 oracle oinstall 4096 Sep 17 2012 resources

    -rwxr-x--- 1 oracle oinstall 993 Sep 17 2012 validate.sh.template

    -rwxr-x--- 1 oracle oinstall 1039 Sep 17 2012 validate.bat.template

    -rwxr-x--- 1 oracle oinstall 738 Sep 17 2012 logging.xml.template

    -rw-r----- 1 oracle oinstall 11580 Sep 17 2012 product_vtconfig.xml

    -rw-r----- 1 oracle oinstall 481280 Aug 1 14:44 validate.tar

     

    resources/

    resources/raframeworkValidation_zh_TW.properties

    resources/raframeworkValidation_zh_CN.properties

    resources/raframeworkValidation_pt_BR.properties

    resources/raframeworkValidation_pl.properties

    resources/raframeworkValidation_it.properties

    resources/raframeworkValidation_ja.properties

    resources/raframeworkValidation_ko.properties

    resources/raframeworkValidation_nl.properties

    resources/raframeworkValidation_de.properties

    resources/raframeworkValidation_es.properties

    resources/raframeworkValidation_sv.properties

    resources/raframeworkValidation_fr.properties

    resources/raframeworkValidation_fi.properties

    resources/raframeworkValidation_ru.properties

    resources/raframeworkValidation_en.properties

    resources/raframeworkValidation.properties

    resources/raframeworkValidation_da.properties

    resources/raframeworkValidation_no.properties

    resources/raframeworkValidation_tr.properties

    validate.bat.template

  • 2. Re: Please comment on configtool.sh hung at 20% when deploying RA Web app
    Mike Paladino Newbie
    Currently Being Moderated

    Hate to give myself a correct answer but it would be best if this post shows it was answered in case someone runs into it, So ill take one for the team

  • 3. Re: Please comment on configtool.sh hung at 20% when deploying RA Web app
    JohnGoodwin Oracle ACE
    Currently Being Moderated

    At least you took the time out to provide the correct answer to the problem which is a lot more than many would do on here

     

    Cheers

     

    John

    http://john-goodwin.blogspot.com/

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points