3 Replies Latest reply: Jul 9, 2013 12:27 AM by user587033 RSS

    Cannot see physical disks in OVM 3.2



      Just installed OVS 3.2 on a dell R910 server with around 2 TB of HDD space. The local storage is under RAID5. The OVM installation was successful with default linux layout. Added this server to the resource pool but i cannot create a repository because it cannot see the physical disks. I have created another partition with the rest of the free space in Server and mounted. Still no luck. What is the best way/steps to use the free space of the local disk as repository in the OVM 3.2?


      Appreciate your support



        • 1. Re: Cannot see physical disks in OVM 3.2



          From what I read in the documentation, local drive space is ONLY available if the drive is not partitioned meaning; a free hard-disk.

          • 2. Re: Cannot see physical disks in OVM 3.2



            Your issue is /dev/sdb

            When you install the OVM server, DON'T select the second partition when you configure your partitions - leave it as RAW space...


            If sdb is partitioned at all, OVM won't accept it as local storage.

            Best Regards

            • 3. Re: Cannot see physical disks in OVM 3.2

              Thanks for your replies

              Agree with first reply, i think OVS cannot see the operating system installed drive no matter of whatever free space left over there. What I did is, broke my RAID and created two VDs, first 2 drives with RAID1 for operating system VD, rest of the drives left for VD2  for local storage. This way OVS could identify the VD2 as local storage. eventhough plenty of space left free unallocated in the first VD where OVS OS is installed, still not available for storage.


              In short, separate disk should be for local storage, not partitions. If anyone has different way to identify OS disk as storage, kindly share.


              Thanks again.