This discussion is archived
1 Reply Latest reply: Jul 15, 2013 7:29 AM by guy.k.hillyer RSS

SNA issues

99f57e83-b01d-4ba2-8f45-351815b9987a Newbie
Currently Being Moderated

I'm trying execute following command:

 

/usr/bin/java -jar /opt/oracle/kv-ee/lib/kvstore.jar ping -host localhost -port 6000

 

and I'm getting following exception:

 

Failed to connect to service commandService Exception message:Connection refused to host: 10.32.17.12; nested exception is: \n#011java.net.ConnectException: Connection refused\nSNA at hostname: localhost registry port: 6000 has no available Admins or RNs registered.'\n+ [[ Failed to connect to service commandService Exception message:Connection refused to host: 10.32.17.12; nested exception is: \n#011java.net.ConnectException: Connection refused\nSNA at hostname: localhost registry port: 6000 has no available Admins or RNs registered

 

Does this mean than the SNA service has some issues? From the docs, I see that if SNA is running (but not configured), it produces following o/p

 

SNA at hostname: node01, registry port: 5000 is not registered.

No further information is available

 

However, if SNA isn't running, then it produces following error:

 

Could not connect to registry at node01:5000

Connection refused to host: node01; nested exception is:

java.net.ConnectException: Connection refused

 

But the error I'm getting is a bit different from this and I'm trying to understand exactly what it means. Does it mean that SNA is healthy but isn't registered yet?

  • 1. Re: SNA issues
    guy.k.hillyer Newbie
    Currently Being Moderated

    The error message is due to a minor bug in Ping.  You may interpret this message as meaning that the SNA is healthy and deployed, but is not running any services yet.

     

    You can bypass this issue entirely by designating (at makebootconfig time) the SNA that will host the first Admin, and running the boostrap Admin only on that one SNA.

     

    You can avoid running the bootstrap Admin by omitting the "-admin <adminPort>" option on the makebootconfig command line.  If you give -admin for only one of the SNAs, then ensure that this SNA is the first to be deployed (and hosts the first Admin), then I think Ping would work correctly for your other SNAs.

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points