This discussion is archived
0 Replies Latest reply: Jul 15, 2013 11:42 PM by 947163 RSS

Problem adding a new node

947163 Newbie
Currently Being Moderated

Hi,

 

Have a clustered domain with one admin and two managed servers( soa servers). Added a new managed server to the existing cluster and after this addition not able to start the Weblogic Server. PFB the error that is being thrown

 

        at com.tangosol.coherence.component.util.SafeCluster.startCluster(SafeCluster.CDB:3)

        Truncated. see log file for complete stacktrace

>

<Jul 15, 2013 12:43:47 PM EDT> <Error> <Deployer> <BEA-149231> <Unable to set the activation state to true for the application 'soa-infra'.

  1. weblogic.application.ModuleException:

        at weblogic.servlet.internal.WebAppModule.startContexts(WebAppModule.java:1510)

        at weblogic.servlet.internal.WebAppModule.start(WebAppModule.java:482)

        at weblogic.application.internal.flow.ModuleStateDriver$3.next(ModuleStateDriver.java:425)

        at weblogic.application.utils.StateMachineDriver.nextState(StateMachineDriver.java:52)

        at weblogic.application.internal.flow.ModuleStateDriver.start(ModuleStateDriver.java:119)

        Truncated. see log file for complete stacktrace

Caused By: java.lang.RuntimeException: Failed to start Service "Cluster" (ServiceState=SERVICE_STOPPED, STATE_JOINING)

        at com.tangosol.coherence.component.util.daemon.queueProcessor.Service.start(Service.CDB:38)

        at com.tangosol.coherence.component.util.daemon.queueProcessor.service.Grid.start(Grid.CDB:6)

        at com.tangosol.coherence.component.net.Cluster.onStart(Cluster.CDB:637)

        at com.tangosol.coherence.component.net.Cluster.start(Cluster.CDB:11)

        at com.tangosol.coherence.component.util.SafeCluster.startCluster(SafeCluster.CDB:3)

        Truncated. see log file for complete stacktrace

>

<Jul 15, 2013 12:43:48 PM EDT> <Notice> <Log Management> <BEA-170027> <The Server has established connection with the Domain level Diagnostic Service successfully.>

<Jul 15, 2013 12:43:48 PM EDT> <Notice> <Cluster> <BEA-000197> <Listening for announcements from cluster using unicast cluster messaging>

<Jul 15, 2013 12:43:48 PM EDT> <Notice> <Cluster> <BEA-000133> <Waiting to synchronize with other running members of dnb_cluster.>

<Jul 15, 2013 12:44:18 PM EDT> <Notice> <WebLogicServer> <BEA-000365> <Server state changed to ADMIN>

<Jul 15, 2013 12:44:18 PM EDT> <Notice> <WebLogicServer> <BEA-000365> <Server state changed to RESUMING>

<Jul 15, 2013 12:44:18 PM EDT> <Notice> <Cluster> <BEA-000162> <Starting "async" replication service with remote cluster address "null">

 

 

 

Intial Configuration in setDomainEnv was as

 

EXTRA_JAVA_PROPERTIES="-Dtangosol.coherence.wka1=node1 -Dtangosol.coherence.wka2=node2 -Dtangosol.coherence.localhost=node1"

 

The above mentioned configuration was working fine with 2 nodes. After the addition of 3rd node changed it in the below mentioned way

 

EXTRA_JAVA_PROPERTIES="-Dtangosol.coherence.wka1=node1 -Dtangosol.coherence.wka2=node2 -Dtangosol.coherence.wka3=node3 -Dtangosol.coherence.localhost=node1"

 

After changing it to above mentioned server startup getting failed.

 

Am i doing something wrong?

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points