4 Replies Latest reply on Jul 23, 2013 4:18 AM by Taco

    Error "424 Object Required" when opening journal report using HFM 11.1.2.1

    Taco

      Hi experts,

       

      I've installed EPM 11.1.2.1 along with Hyperion Financial Management and Financial Reporting on an virtual machine (OS is windows server 2008),

      when I logon to workspace and tried to open an journal report in HFM-Format, appears error message as follows:

       

      An error has occurred. Please contact your administrator


      Error Number:424

      Error Description: Object required

      Error Source: Microsoft VBScript runtime error

      Page On which Error Occurred:../reports/CheckStatus.asp


      I've checked oracle support and found article ID 967025.1 describing almost the same issue of mine,

      but the suggested solution was to add workspace and HFM web server to trusted site. (I'm using IE9)

      I did so as well as other recommended browser settings but still the error remains.


      The article said the solution was applied to Version 9.2.0.0 to 11.1.1.3, so I'm not sure if version 11.1.2.1 has other causes or solutions.


      Could experts provide any ideas?

        • 1. Re: Error "424 Object Required" when opening journal report using HFM 11.1.2.1
          SDM

          I believe you might have already done with the below steps, but please reconfirm:

           

          1) Ensure, that both the Hyperion Workspace URL AND the HFM webservername i.e(Http://<hfmwebservername>/hfm) is added in the sites button in the Trusted sites option. under Security tab.

          2) Here is a list of Internet Explorer settings which are recommended to be set on the client machine:

           

           

          1. Configure browser to check for new version every time user visits a page

           

           

          * Open Internet Explorer

          * Go to Tools > Internet options > General

          In 'Browsing history' section select 'Every time I visit the webpage'

          * Click Ok, then Apply.

           

           

          2. Disable default pop-up blocking

           

           

          * Open Internet Explorer

          * Go to Tools > Internet options > Privacy tab

           

           

          Uncheck 'Turn on Pop-up Blocker'

           

           

          3. Add workspace URL to trusted sites

           

           

          * Open Internet Explorer

          * Go to Tools > Internet options > Security tab

          * Select Trusted sites from Select a zone to view or change security settings.

          * Type your workspace URL in form http://workspaceserver:portnumber in 'Add this website to the zone'

          * Uncheck 'Require server verification (https:) for all sites in this zone'

          * Click Add, then Close.

          * Click Ok and Apply.

           

           

          4. Minimize security setting for trusted sites

           

           

          * Open Internet Explorer

          * Go to Tools > Internet options > Security tab

          * Select Trusted Sites from select a zone to view or change security settings

           

           

          * Select custom level

           

           

          * From Reset to list select Low

          * Click Ok

          * Click Apply, then Ok

           

           

          5. Customize security settings

           

           

          * Open Internet Explorer

          * Go to Tools > Internet options > Security Tab > Custom Level

          * In 'Miscellaneous' section enable the option "Allow script-initiated windows without size or position constraints"

          * In 'ActiveX controls and plug-ins' section enable “Run ActiveX controls and plug-ins” and “Script ActiveX controls marked safe for scripting.”

           

           

          6. Enable option "Always allow session cookies".

           

           

          * Open Internet Explorer

          * Go to Tools > Internet options > Privacy Tab > Advanced > Check the "Override automatic cookie handling" and accept the first and third party cookies and check the "Always allow session cookies" option.

           

           

          7. Disable option "Enable Native XMLHTTP".

           

           

          * Open Internet Explorer

          * Go to Tools > Internet options > Advanced Tab > Uncheck the option "Enable Native XMLHTTP"

           

          If still facing the same issue, perform the below action plan:

           

          1) Give full permission to Filetransferfolder and try generating the reports.

           

          2) Add the Everyone user and dcom user to BIPubSystemReports.

           

          DCOM Config-> BIPubSystemReports-> Security tab-> add the users in Launch and Activation Permission, Access permissions and Configuration Permissions.

           

          Best regards.

          • 2. Re: Error "424 Object Required" when opening journal report using HFM 11.1.2.1
            Taco

            Hi SDM,

             

            Thanks for reply.

             

            I've done and confirmed all the browser settings.

            (The server only allows me to set the trusted site security to mid-low, but I customized it and enabled those options needed)

             

            I've set full control permission to Filetransferfolder, including "everyone","NETWORK SERVICE", "IUSR", "Administrators", "Authenticated Users"(I add it in additionally according to other sources).

             

            I used account "Administrator" as DCOM user while configuring HFM, which is a member of group "Administrators",

            and I've granted group "Administrators" and "everyone" full permission to BIPubSystemReports just as you recommended.

            But still could not solve the issue.

             

            For more information, I had patched this server with HFM PSU 11.1.2.1.601(16191515) and PSE 11.1.2.1.601(16709689) before.

             

            Do you have any other ideas?

            • 3. Re: Error "424 Object Required" when opening journal report using HFM 11.1.2.1
              SDM

              Have you started facing this issue after applying the above patches? If yes, run lsinventory and see if the patches are properly installed.

              Also, I would like to have a look at your latest log file/s. Archive and delete your old and attach your latest HsvEvent log file from all the server/s.

               

              Thanks.

              1 person found this helpful
              • 4. Re: Error "424 Object Required" when opening journal report using HFM 11.1.2.1
                Taco

                Hi SDM,

                 

                I applied the patch by the time I've done system installation, so the issue occurred after applying the patch.

                 

                After try'in to rollback from patch id 16709689 (PSE), the problem solved. So it seems to be caused by the patch.

                 

                Still don't know if it's a bug or something.