1 Reply Latest reply: Jul 22, 2013 4:39 AM by rukbat RSS

    Exalogic cloud - vlan bond1 issue

    narayana

      Hi,

       

      vlan module: 8021q used

       

      For example
      ref link; http://docs.oracle.com/cd/E18476_01/doc.220/e18478/commproc.htm#BEIHAIDA --- here they used multiple physical hosts not single ethernet port

      Here 
      in bracket oracle details and other is my details

      1)  eth0 (1A-ETH-3) - ethernet port
      2)  vlan121 (eth4, vlan 10 ) -     vlan 121
      3)  vlan122 (eth5, vlan 11 ) -      vlan 122


      I have a exalogic machine which has Oracle Linux 5.6- x64 bit

       

      Created 2 VLANs with IP and bond interface if i start network service [service network restart], I

       

      get hardware address conflicts error message on vlan 121, 122

       

      i have 1 physical lan cord, creating eth0, multiple vlans, bond1, bond0 interfaces

       

      i could see eth0 192.168.1.12, bond1 192.168.48.128 but vlan121, vlan122 no static ips displayed

       


      Question : How can i build vlan121, vlan122 ip address should set as static ips (or) based on hardware address

       

      when i run #ifconfig -a ==> default HwAddr displays common for all the vlans, bond1, eth0

       


      # vim /etc/sysconfig/network-scripts/ifcfg-vlan121

       

      DEVICE=vlan121

       

      BOOTPROTO=none

       

      ONBOOT=yes

       

      IPADDR=192.168.48.129

       

      #HWADDR=a2:c0:a0:a8:01:01

       

      VLAN=yes

       

      PHYSDEV=eth0

       

      VLAN_NAME_TYPE=VLAN_PLUS_VID_NO_PAD

       


      MASTER=bond1

       

      SLAVE=yes

       


      # vim /etc/sysconfig/network-scripts/ifcfg-vlan122

       

      DEVICE=vlan122

       

      BOOTPROTO=none

       

      ONBOOT=yes

       

      IPADDR=192.168.48.130

       

      #HWADDR=a2:c0:a0:a8:01:01

       

      VLAN=yes

       

      PHYSDEV=eth0

       

      VLAN_NAME_TYPE=VLAN_PLUS_VID_NO_PAD

       


      MASTER=bond1

       

      SLAVE=yes

       


      # vim /etc/sysconfig/network-scripts/ifcfg-bond1

       

      DEVICE=bond1

       

      IPADDR=192.168.48.128

       

      NETMASK=255.255.255.0

       

      BOOTPROTO=none

       

      USERCTL=no

       

      TYPE=Ethernet

       

      ONBOOT=yes

       

      IPV6INIT=no

       

      BONDING_OPTS="mode=active-backup miimon=100 downdelay=5000 updelay=5000"

       

      GATEWAY=192.168.48.1