1 Reply Latest reply: Jul 22, 2013 3:03 PM by Turloch O'Tierney-Oracle RSS

    SqlDev 4 EA1

    VicC

      This is an interesting one, using 12c, I'm logged on as sys/<password>@PDB1 as sysdba and I open sql worksheet and do a select * from v$database;

      I use the 'Run Statement' button and I get a query result which I would expect as normal. However I run the same sql and click the button 'Run Script' and I get the headings but no values below those headings. I guess that's what Early Adopter releases are for!

       

      I have also tried the same scenario on a CDB as sysdba and 11.2.0.3 as sysdba running the same sql.

       

      Regards,

       

      VicC

        • 1. Re: SqlDev 4 EA1
          Turloch O'Tierney-Oracle

          Hi VicC,

           

          >I have also tried the same scenario on a CDB as sysdba and 11.2.0.3 as sysdba running the same sql.

          You do not say what the result was. I am assuming it worked on CDB and 11.2.0.3.

           

          select * from v$database; -- works for me though there is a lot of formatting code between the database and the display.

           

          If I can reproduce I can log a bug and work from the code in debug mode.

           

          I want to reproduce and / or cut down where the issue might be:

          1/Try other sqlplus or SQLDeveloper against PDB1

          eg. SQLDeveloper 3.2.2 against PDB1 (if Production 3.2.2 does not work you can go through Oracle Support), 12c sqlplus against PDB1, or 11.2.0.3 sqlplus against PDB1

           

          I listed out various SQLDeveloper worksheet/sqlplus emulation issues in a blog post SQLDeveloper Senior Member of Tech Staff blog: User check on sqldeveloper (worksheet) issue - I will add to it if there is significant interest.

           

          2/Try to find out what part of v$database is causing the issue

          try count(*), subsets of the columns, to_char() on any problem columns so more conversion is done on the database rather than SQLDeveloper

          3/Try other user - system

          (This is unlikely to be useful but worth a try if nothing else shows promise)

          4/There is debugging/log information

          e.g.Most serious java issues cause a message to the screen ('Java Stack Trace') if you start sqldeveloper from ide/sqldeveloper/bin from the command line

          5/try as a different operating system user

          in case your per user settings are corrupt. (This is pretty  general advice not worksheet specific)

           

          -Turloch

          SQLDeveloper Forum