8 Replies Latest reply on Jul 24, 2013 3:47 PM by Vijay Inani

    Not able to see my deployed Application in BPM workspace

    Vijay Inani

      Hi Mates,


      I am a newbie to BPM.


      I was trying a tutorial of BPM at : http://www.oracle.com/webfolder/technetwork/tutorials/obe/fmw/obpm/11g/r1/firstProcess/firstprocess_obpm11g.htm


      I successfully developed the complete process and the associated UI. I also deployed the same as mentioned in the steps in the link above.


      But, it the tutorial its stated that:


      Instantiate the process by clicking the HelloWorldProcess v1.0 link under Applications in the Tasks tab on the left side of the window.

      Note: If the HelloWorldProcess v1.0 link does not appear in the Applications panel on the Tasks tab, click the Process Tracking tab. It should appear there. You can instantiate the process from that tab.


      But, I can neither see the HelloWorldProcess v1.0 under Applications, nor under Process Tracking tab.


      I am using JDev and Weblogic server version is 10.3.6


      Please suggest as what should be done or where I am going wrong?


      Let me know if any additional inputs are required from me.





      Vijay Inani

        • 1. Re: Not able to see my deployed Application in BPM workspace
          ravi piplani

          Please check if you have assigned the user to proper role.


          For eg: In your case, role would be 'Requestor'. Check if you have assigned the username (one you are using to login to workspace) to the 'Requestor' role.



          1 person found this helpful
          • 2. Re: Not able to see my deployed Application in BPM workspace
            Ravi Jegga

            This may help. Basically for any BPM Application, you will have Roles / Swimlanes defined in JDeveloper. Now after deploying this from EM Console you should add some Users or Groups to these Roles. The user can be created from weblogic console in default authenticator. Finally for most of the out of box Demos from Oracle for any product like soa, bpm, bi or xyz, they refer to set of users like jcooper, jstein etc etc. All these are created using another sample application from Oracle. Below link should help.


            Re: Realm is not populated for BPM app



            Ravi Jegga

            • 3. Re: Not able to see my deployed Application in BPM workspace
              Vijay Inani

              Hi Ravi and Ravi Jegga,


              I have tried both the options earlier, but it didn't work for my manual process.


              Then I created a Async. process with the same tutorial and this time it worked fine.


              Still not sure why it didn't work for Manual process.


              Thanks Anyways!


              Vijay Inani

              • 4. Re: Not able to see my deployed Application in BPM workspace
                Dan Atwood

                Hi Vijay,


                Here's what I think that it might be.  Look at your process and compare your process with the one shown at the top of the tutorial.  Notice that your "Request Hello" activity probably does not have the green triangle inside of it like the one in the picture has.  If this is not the case then don't read the rest of this post.


                The interactive activity with the green triangle is called an Initiator activity and only these activities are shown in your Applications tab. 


                I'm not sure how this might have happened because when you add the process in step 4 of the Creating the Process Model section, it automatically adds the initiator activity for you in the process.  The tutorial is confusing because the screenshots of the process in steps 4, 5, 7 and 8 in the "Creating the Process Model" section do not show the Initiator activity but instead incorrectly show a simple User activity.


                In the Implementing the User Task section of the tutorial, as you are creating the human task for the interactive User task it has you make sure its pattern is set to "Initiator" (search the tutorial for the text "Initiator" and you'll see it).


                If it is not set to "Initiator", then it is probably set to the "Simple" and you will not see the green triangle in the activity.  You can fix it by repeating steps 1 and 2 in the Implementing the User Task section of the tutorial (making sure that you select the Initiator from the "Pattern" dropdown and give it the name "SayHello2").


                Do steps 3 and 5 again in the Adding the Review Message Human Interaction section but pick your new "SayHello2.task" task file instead of picking the "ReviewMessage.task".  In step 5, instead expanding the "HelloWorld_UI_ReviewMessage" data control, instead expand your new "HelloWorld_UI_SayHello2.  Redeploy the project.


                Hope this gets you going,


                1 person found this helpful
                • 5. Re: Not able to see my deployed Application in BPM workspace
                  Vijay Inani

                  Hi Dan,


                  Thank you for the detailed explanation.

                  I checked my process and found that the "Request Hello" activity has "Initiator" pattern.


                  Please find the screenshot of the same at  : http://img607.imageshack.us/img607/8195/cyf3.png


                  Please check the same.


                  In one of the post at https://forums.oracle.com/thread/2138336 , its mentioned that "My server lesser RAM then recommended by Oracle and domain was extended with web center. I created a new domain without webcenter and deployed the process and all is well" by 'ZeeshanBaiG' at the end of the thread. Could that be the cause?


                  Thanks and Regards,

                  Vijay Inani

                  • 6. Re: Not able to see my deployed Application in BPM workspace
                    Vijay Inani

                    I am using JDev and WLS 10.3.6. I am not sure if my soa domain is extended with web center as mentioned in the link posted above.


                    - Vijay

                    • 7. Re: Not able to see my deployed Application in BPM workspace

                      You should verify 2 things:

                      -bpm workspace -> administration: is your test user assigned directly or indirectly via a group to the requester role (if not, assign him and use the refresh icon in the applications tab)

                      -em -> you process -> request hello task -> administration: you should see there the used server/port and the uri for the adf mask (if those parameters are missing for an initiator task then the process is not visible under the applications)

                      • 8. Re: Not able to see my deployed Application in BPM workspace
                        Vijay Inani

                        Hi All,



                        Thanks everyone for the replies and help.

                        Finally, I was able to see the HelloWorldProcess under Applications in BPM Workspace.

                        Actually, the problem was:

                        As per the tutorial, it was asked to rename the application role from HelloWorldProcess.Role to HelloWorldProcess.Requester.

                        I did the same, but here only the display name was changed to HelloWorldProcess.Requester and the actual name remained to HelloWorldProcess.Role

                        So, in BPM Workspace > Administration, I created a new Application role HelloWorldProcess.Requester and assigned a group and user to it.

                        When logged in with the same user/group, I was able to see the manual process now.

                        Nice learning!



                        I have just started with BPM. It would be helpful if you guys can provide me with more complex tutorials links and design principles for the same.

                        Help will be appreciated!



                        Thanks and Regards,

                        Vijay Inani