1 Reply Latest reply: Aug 6, 2013 7:06 AM by pershad2k RSS

    JMS Adapter Tuning in Oracle 10G SOA suite - Fixing the Errors

    pershad2k

      Hi All,

       

      We are getting an error in Production environment while a BPEL process producing (enqueue) a message to a JMS queue by using JMS adapter. (partener link)

      The error is as follows.

       

      Adapter Framework unable to create outbound JCA connection.

      file:/sw/appnew/product/SOA/10.1.3/bpel/domains/default/tmp/.bpel_CurrenListJMSProducer_1.0_4ec528ec93a8a6ff0278fab9701dcc71.tmp/CurrenListJMSProducerV1.wsdl [ Produce_Message_ptt::Produce_Message(OutputParameters) ] - : The Adapter Framework was unable to establish an outbound JCA connection due to the following issue: oracle.j2ee.connector.proxy.ProxyInterceptException: javax.resource.ResourceException: RollbackException: Transaction has been marked for rollback: null [Caused by: RollbackException: Transaction has been marked for rollback: null]

       

      Please note that we are not getting this error every time,  few BPEL instances are getting this error, around 3 out of 10 instances.


      We are using Orcacle 10G SOA suite.

      The BPEL process will take the messages from Oracle Apps adapter and  send to the JMS queue, where we are getting error.

      I can see in the BPEL.xml  the "retryInterval" property set to '60' for both partner links (Apps adapter and JMS adapter).

      But not set any other values. So,these values may be default.

       

      We need to fix this issue soon.

      I am requesting you all the Experts and Gurus, please let me know what can be done to fix this issue.


      Thanks a lot in advance,

      John.


        • 1. Re: JMS Adapter Tuning in Oracle 10G SOA suite - Fixing the Errors
          pershad2k

          Hi All,.

           

          Is there any work around for the above issue?

           

          I tried all the below JMS tunings, but not no improvement.

           

                      <property name="useJCAConnectionPool">true</property>

                      <property name="maxSizeJCAConnectionPool">500</property>

                      <property name="retryMaxCount">10</property>

                      <property name="retryInterval">60</property>

           

          Please let

           

          me know if any other logs or any other information is required in order to analyse the issue.

           

          Thanks,

          John