7 Replies Latest reply on Jul 29, 2013 5:07 AM by NasirAmin

    Remote deployment failed

    NasirAmin

      Hi, anyone can help me please ? I am trying to deploy the application from last two days on the remote server, but don't know whats wrong with this.

       

      [05:39:12 PM] ----  Deployment started.  ----

      [05:39:12 PM] Target platform is  (Weblogic 10.3).

      [05:39:13 PM] Retrieving existing application information

      [05:39:13 PM] Running dependency analysis...

      [05:39:13 PM] Building...

      [05:39:14 PM] Deploying 4 profiles...

      [05:39:15 PM] Wrote Web Application Module to C:\JDeveloper\mywork\KNM\All Approvals\APPViewController\deploy\All Approvals_APPViewController_webapp.war

      [05:39:15 PM] Moving WEB-INF/adfc-config.xml to META-INF/adfc-config.xml

      [05:39:15 PM] Wrote Archive Module to C:\JDeveloper\mywork\KNM\All Approvals\APPViewController\deploy\AdfLIBallApproval.jar

      [05:39:15 PM] Wrote Archive Module to C:\JDeveloper\mywork\KNM\All Approvals\APPModel\deploy\All Approvals_APPModel_adflib.jar

      [05:39:16 PM] Wrote Enterprise Application Module to C:\JDeveloper\mywork\KNM\All Approvals\deploy\ApprovalEARDeploy.ear

      [05:39:16 PM] Deploying Application...

      [05:39:20 PM] [Deployer:149193]Operation 'deploy' on application 'ApprovalEARDeploy' has failed on 'AdminServer'

      [05:39:20 PM] [Deployer:149034]An exception occurred for task [Deployer:149026]deploy application ApprovalEARDeploy on AdminServer.: Failed to load webapp: 'All-Approvals-APPViewController-context-root'.

      [05:39:20 PM] Weblogic Server Exception: weblogic.application.ModuleException: Failed to load webapp: 'All-Approvals-APPViewController-context-root'

      [05:39:20 PM] Caused by: weblogic.management.DeploymentException: Error: Unresolved Webapp Library references for "ServletContext@47003767[app:ApprovalEARDeploy module:All-Approvals-APPViewController-context-root path:/All-Approvals-APPViewController-context-root spec-version:2.5]", defined in weblogic.xml [Extension-Name: jsf, Specification-Version: 2, exact-match: false]

      [05:39:20 PM]   See server logs or server console for more details.

      [05:39:20 PM] weblogic.application.ModuleException: Failed to load webapp: 'All-Approvals-APPViewController-context-root'

      [05:39:20 PM] Deployment cancelled.

      [05:39:20 PM] ----  Deployment incomplete  ----.

      [05:39:20 PM] Remote deployment failed (oracle.jdevimpl.deploy.common.Jsr88RemoteDeployer)

        • 1. Re: Remote deployment failed
          Wes Fang

          whats your jdev version?

           

          can you open the "EAR Deployment Profile properties" window from Application -> Application Properties -> Deployment -> Application Assembly

          You should see a Model and ViewController.jpr.


          What is the dependency you have configured?

          1 person found this helpful
          • 2. Re: Remote deployment failed
            Timo Hahn

            [05:39:20 PM] Caused by: weblogic.management.DeploymentException: Error: Unresolved Webapp Library references for "ServletContext@47003767[app:ApprovalEARDeploy module:All-Approvals-APPViewController-context-root path:/All-Approvals-APPViewController-context-root spec-version:2.5]", defined in weblogic.xml [Extension-Name: jsf, Specification-Version: 2, exact-match: false]

            tells you that the remote server doesn't have the right ADF runtime installed. Check if the target server has a adf runtime installed which matches the jdev version you use to develop the application. Check JDeveloper Versions vs. Weblogic Server Versions | JDev & ADF Goodies for matching versions.

             

            Timo

            • 3. Re: Remote deployment failed
              NasirAmin

              Bundle of thanks Timo, you made my life simple

              I have Jdeveloper version 11.1.2.0.0 and the Web logic Server version in the target server is 10.3.5. Which is not compatible as i read the document you provided me.

              In the document they give me two options, 11.1.1.5.0 also  11.1.1.6.0 so which will be more suitable for weblogic server 10.3.5, according to your experience ?

              • 4. Re: Remote deployment failed
                NasirAmin

                Thanks you WesFang,

                I can see my view Controller as well as the Model , I checked both the libs in the Application Assembly and I think I have the version compatibility problem as Timo told me below, I am gonna update my Jdeveloper versions then later I will be back here if I will have any problem, Thanks a lot,

                • 5. Re: Remote deployment failed
                  Timo Hahn

                  Hi, check the table in the blog again. You can use wls 10.3.5 with you Jdev version. You have to apply the Sherman patches to the server. You get them via Oracle support.

                  As you have developed you application using Jdev 11.1.2.0.0 you can't just go back to a 11.1.1.x version.  Your version and the 11.1.1.x versions are using different technologies under the hood. Check out http://tompeez.wordpress.com/2013/05/20/case-study-backporting-a-jdeveloper-project-from11gr2-to-11gr1/ to find out more about this.

                  If you want to upgrade 12c it's Ann option.

                   

                  Timo

                  1 person found this helpful
                  • 6. Re: Remote deployment failed
                    NasirAmin

                    Hi, TimeHahn I have installed the jdev 11.1.1.5.0 after downloading it, Now I tried to deploy my test application on wls 10.3.5 it gives the following exception.

                     

                    An error occurred during activation of changes, please see the log for details.

                    weblogic.application.ModuleException:

                    java.security.PrivilegedActionException: weblogic.common.ResourceException: java.security.PrivilegedActionException: weblogic.common.ResourceException: No credential mapper entry found for password indirection user=CONT for data source KnmTestConn

                    • 7. Re: Remote deployment failed
                      NasirAmin

                      Bundle of Thanks TimoHahn, Now my application is working very well, everything is fine, I have solved all the problems, Thanks again