14 Replies Latest reply: Aug 11, 2013 2:29 PM by Hussein Sawwan-Oracle RSS

    No client JVM when running rapidwiz 12.1.1

    RaviprakashaM

      Hi All,

       

      I am trying to istall the Oracle EBS R12.1.1 on OEL 5 Update 8 on VM Player.

       

      I am using the shared folder as the staging area ( I have the staging are in my Windows 7 system , which I have shared with the OEL).

       

      when running the startCD rapidwiz , I am getting the below error

      Error: no `client' JVM at `/mnt/ntfs/R12Stage/startCD/Disk1/rapidwiz/jre/Linux_x64/1.6.0/lib/i386/client/libjvm.so'.

       

      I tried one of the  solutions mentioned in the forum by downloading the Java JRE 1.6.0_34 (jre-6u34-linux-x64.bin). Then Extracted it in jre/Linux_X64 folder  and renamed it to 1.6.0 .

      But It did not work , still giving the same error.

      Also I tried using the latest patch for the startCD p11072566_R12_GENERIC.zip.

      But still I am getting the same error.


      Can anybody help me on this.

      Thanks and Regards,

      Ravi

        • 1. Re: No client JVM when running rapidwiz 12.1.1
          Asif Muhammad

          Hi Ravi,

           

          Can you run the MD5SUM check on the staging area and let us know the integrity is perfect.

          Can you also run command "java -version" and provide the output

           

          In addition I also recommend to have a look at:

          [Bug 56545] amd64: Error: no `client' JVM at ...

           

          BTW, run the rapidwiz command; once the error message is in place see if you can find any valuable error message to troubleshoot from "cat /var/log/messages" and "dmesg"

           

          Hope this helps!

          Best Regards,

          • 2. Re: No client JVM when running rapidwiz 12.1.1
            ora_tech

            Hi,

             

            Please refer MOS tech note for MD5 checksum:

             

            MD5 Checksums for R12.1.1 Rapid Install Media (Doc ID 802195.1)

             

            Please make sure that you are using the appropriate stage software ( 32-bit software on 32-bit OS/64-bit sw for 64-bit OS)

             

            Also make sure all per-requisites are in place.

             

            thanks,

            X A H E E R

            • 3. Re: No client JVM when running rapidwiz 12.1.1
              RaviprakashaM

              Hi Xaheer,

               

              Thanks you.I have run the MD5SUM against the stage directory. It was successful.

              But when I ran the MD5SUM check for startCD(patch 6641342) it is throwing many 'Directory not found' and 'Failed to open or read' messages.

              Not sure what is the reason.  Could you please let me know how I can proceed.

               

              Thanks and Regards,

              Ravi

              • 4. Re: No client JVM when running rapidwiz 12.1.1
                RaviprakashaM

                HI Asif,

                 

                Thanks for your inputs.

                I have done the below checks.

                1. md5sum checks against stage area :

                 

                 

                ran the md5sum check for the stage area . There are no errors. Every thing is showing OK.

                But when I ran the MD5SUM check for startCD(patch 6641342) it is throwing many 'Directory not found' and 'Failed to open or read' messages.

                 

                 

                 

                 

                2.Java version

                 

                 

                Java Version :-

                java version "1.4.2"

                gij (GNU libgcj) version 4.1.2 20080704 (Red Hat 4.1.2-52)

                 

                 

                3. IN the log there are no errror messages

                 

                 

                in dmesg :I am getting the below error

                 

                Error: Driver 'pcspkr' is already registered, aborting...

                lp0: using parport0 (interrupt-driven).

                lp0: console ready

                SELinux: initialized (dev ramfs, type ramfs), uses genfs_contexts

                NET: Registered protocol family 10

                md: Autodetecting RAID arrays.

                md: Scanned 0 and added 0 devices.

                md: autorun ...

                md: ... autorun DONE.

                EXT3 FS on dm-0, internal journal

                kjournald starting.  Commit interval 5 seconds

                EXT3 FS on sda1, internal journal

                EXT3-fs: mounted filesystem with ordered data mode.

                SELinux: initialized (dev sda1, type ext3), uses xattr

                SELinux: initialized (dev tmpfs, type tmpfs), uses transition SIDs

                Adding 4095992k swap on /dev/VolGroup00/LogVol01.  Priority:-1 extents:1 across:4095992k

                SELinux: initialized (dev binfmt_misc, type binfmt_misc), uses genfs_contexts

                 

                Kindly let me know is there any inference from my inputs and let me know how can go ahead.

                 

                Thanks and Regards,

                Ravi

                • 5. Re: No client JVM when running rapidwiz 12.1.1
                  Hussein Sawwan-Oracle
                  I am using the shared folder as the staging area ( I have the staging are in my Windows 7 system , which I have shared with the OEL).

                   

                  How was the staging area directory created? Did you download the correct Rapid Install files for Linux OS? Were the files extracted from Windows or on the Linux machine?

                   

                  Thanks,

                  Hussein

                  • 6. Re: No client JVM when running rapidwiz 12.1.1
                    Hussein Sawwan-Oracle

                    RaviprakashaM wrote:

                     

                    Hi Xaheer,

                     

                    Thanks you.I have run the MD5SUM against the stage directory. It was successful.

                    But when I ran the MD5SUM check for startCD(patch 6641342) it is throwing many 'Directory not found' and 'Failed to open or read' messages.

                    Not sure what is the reason.  Could you please let me know how I can proceed.

                     

                    Thanks and Regards,

                    Ravi

                     

                    What do you mean by running md5sum for startCD? You should run md5sum for the whole stage area directory (including startCD) and see if you get any errors.

                     

                    It would be helpful if you could upload the output of md5sum command to any free hosting website and post the link here so we can review the file.

                     

                    Thanks,

                    Hussein

                    • 7. Re: No client JVM when running rapidwiz 12.1.1
                      RaviprakashaM

                      Actually I got the complete rapid install package from one of my friends who had downloaded it and extracted it in his machine. Also he was successful in installing  the ebs.

                      I am using the same set of files.I havent set up the staging area in Oracle Linux. What I have done is ,have copied the files into my windows OS C:/R12Stage  folder and share this folder with the VM. Also I have run the command chmod 777 * aginst this folder from Oracle Linux.

                      Let me know if I have gone wrong somewhere.

                       

                      Thankd and Regards,

                      Ravi

                      • 8. Re: No client JVM when running rapidwiz 12.1.1
                        Asif Muhammad

                        Hi Ravi,

                         

                        What I have done is have copied the files into my windows OS C:/R12Stage  folder and share this folder with the VM.

                         

                        As far as I know, you will have to create a samba server in order to make a share between Linux OS and a Windows OS, otherwise even if you provide 777 permission it would be not helpfule.

                         

                        Could you please try to read, create the file from linux to the share and let us know.

                         

                        BTW, what I would really suggest is if you have enough space on the linux box, please try to stage it to the Linux box and let us know if the issue persist.

                         

                        Best Regards,

                        • 9. Re: No client JVM when running rapidwiz 12.1.1
                          RaviprakashaM


                          Thanks Asif,

                          Yes, I have a limited(around 200 GB but not extra) space in my hard drive. Will try to allocate some more space to VM and set up the stage area in Linux box check if it goes well.

                          Will update the thread on my progress.

                           

                          Thanks and Regards,

                          Ravi

                          • 10. Re: No client JVM when running rapidwiz 12.1.1
                            Hussein Sawwan-Oracle

                            Please run md5sum on the stage area directory before you kick off the installation again and make sure you use the latest startCD and you get no errors when running md5sum.

                             

                            Thanks,

                            Hussein

                            • 11. Re: No client JVM when running rapidwiz 12.1.1
                              RaviprakashaM

                              Hi Hussein,

                               

                              Is the patch 11072566 latest one for R12.1.1 startCD. I am using this , please let me know is this the right one ..?

                               

                              Thanks and Regards,

                              Ravi

                              • 12. Re: No client JVM when running rapidwiz 12.1.1
                                RaviprakashaM

                                Also Now I am getting a different error ( I have replaced teh jre 1.6.0 with 1.6.0_45 now)

                                Error occurred during initialization of VM

                                java/lang/NoClassDefFoundError: java/lang/Object

                                 

                                Could you please guide me what this error may point to.

                                 

                                Thanks and Regards,

                                Ravi

                                • 13. Re: No client JVM when running rapidwiz 12.1.1
                                  Asif Muhammad

                                  Hi Ravi,

                                   

                                  Is the patch 11072566 latest one for R12.1.1 startCD

                                  Yes it the latest Rapid Install Start CD patch.

                                   

                                  Please refer below link:

                                  https://blogs.oracle.com/stevenChan/entry/new_rapid_install_startcd_12

                                   

                                  Best Regards,

                                  • 14. Re: No client JVM when running rapidwiz 12.1.1
                                    Hussein Sawwan-Oracle

                                    RaviprakashaM wrote:

                                     

                                    Also Now I am getting a different error ( I have replaced teh jre 1.6.0 with 1.6.0_45 now)

                                    Error occurred during initialization of VM

                                    java/lang/NoClassDefFoundError: java/lang/Object

                                     

                                    Could you please guide me what this error may point to.

                                     

                                    Thanks and Regards,

                                    Ravi

                                     

                                    Was this done after a successful installation? If yes, did you follow the steps in (Deploying JRE (Native Plug-in) for Windows Clients in Oracle E-Business Suite Release 12 (Doc ID 393931.1))?

                                     

                                    Assuming the installation was completed successfully and you have followed all the steps in the doc, please check Apache log files as well as applocation.log files for details about the error.

                                     

                                    Please note that updating JRE client is different than updating Java on the apps/db tier nodes -- Overview of Using Java with Oracle E-Business Suite Release 12 (Doc ID 418664.1)

                                     

                                    Thanks,

                                    Hussein